Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

LabView LINX - Connection to the target (raspberrypi) has been lost

Go to solution

Hello all,


I am attempting to run the LabVIEW LINX example Blink_Advanced VI but seem to be falling at the first hurdle.


I can connect to the raspberry pi OK but when I run the Blink VI I get the error 'Warning: Connection to the target (raspberrypi) has been lost.'


I click ok and the VI stops.


I right click the Raspberry Pi entry in the project file and try to connect to the Pi again and get the error message 'failed to connect to the target'


I have looked through various forums and people have said could be a PSU issue.

I am using a 5V 3A PSU so shouldn't be that, plus I am running the pi with no monitor or mouse and keyboard.


I have attached some images of my system configuration and error messages that I am seeing.

I am running LabVIEW 2020 professional and have downloaded the latest version of Labview LINX.


If anyone can offer any assistance it will be much appreciated,


Thanks in advance,




0 Kudos
Message 1 of 11

Are you using a Raspberry Pi 1 (Model A, B, B+, Zero, etc). The Broadcom CPU BCM2835 in your image would indicate that, but the Raspberry Pi 1 is not compatible with Linx as a target to download LabVIEW VIs to. It's ARM CPU architecture is not supported.


Linx needs a BCM2836, BCM2837, BCM2837B0, or BCM2711 CPU in order to support using the Raspberry Pi as LabVIEW target.


Rolf Kalbermatter
My Blog
0 Kudos
Message 2 of 11

Hello Rolfk,


Thanks for getting back to me.

I am using a raspberry pi 3 model B V1.2.


the marking on the broadcom chip reads bcm2837rf1bg


0 Kudos
Message 3 of 11

I use a Raspberry Pi 3 model B v1.2 and have no connection issues so I don't think it is your hardware.


Since you are using LabVIEW Professional you can check out my post here where I went over the software I used to get this to work.  See if anything jumps out as being different.


What OS are you running on the Raspberry Pi?  I use Raspberry Pi OS (32-bit) with desktop Version: August 2020 Release date: 2020-08-20 last time I started up a new image.  Maybe there is an issue with the image you are using.


Another question I had is what is your exact process when you try to run the VI?  It appears that you are connecting through the project and then running the VI, correct?  I believe you can just run the VI without connecting through the project and when you run the VI it will deploy and connect.  If you are not doing it this way can you try that and report back your experience?

David Wilt
The New Standard LLC
0 Kudos
Message 4 of 11

Hello David,


I am running the latest release of Pi OS (32 bit). Release 3.6 January 2021

not sure how to find out what desktop version it is?


I also have the LV2020 Runtime installed.




I have also tried to just run the VI without connecting the pi first and get the same error.







0 Kudos
Message 5 of 11

As I have not used Release 3.6 I cannot firm that this build works.  The desktop version just means the OS version with a built in desktop.


Do you have LabVIEW RT installed also?  I found that mine did not work without that installed.


Also, what version of LabVIEW are you using, 32-bit or 64-bit?  I have only used 32-bit LabVIEW when connecting to a Raspberry Pi.


How are you connecting to the Raspberry Pi, WiFi or Ethernet?  If you are using WiFi you may want to try Ethernet as something on the network could actually be closing the connection.  Maybe also try a direct Ethernet connection instead of through a router.

David Wilt
The New Standard LLC
0 Kudos
Message 6 of 11
Accepted by topic author Goomba79

Hello David,


I have managed to get it working!

What was causing my issue was I had the 1-wire interface enabled.

(Preferences > Raspberry Pi Configuration > Interfaces)


I disabled this and it now connects and runs fine.


The other confusing thing is that in the Digital output you set seems to refer to 40 way pin number rather than GPIO number??

i.e. I set Digital Output as 7 in the VI expecting GPIO 7 (pin 26) to pulse but GPIO 4 (pin 7) pulses.


Message 7 of 11



Thanks for you help!! It's working!!



0 Kudos
Message 8 of 11

Hi !


I have a similar problem but disabling 1-wire interface did not solve the problem.

In brief, I have:

  • a Raspberry Pi 3B, formatted with the latest Raspberry Pi OS (October 30th 2021).
  • Labview Community Ed. 2021
  • All Pi's interfaces enabled, except VNC and 1-wire. SSH communication works ok.

Now, in a fresh Labview CE installation,in: Tools-Hobbyist-Target Configuration, I successfully establish connection in the 1st screen ("Connection"). Then in "Installation", I can see the Available Version=21.0.0-1, but Installed Version remains blank, even if I click on "Upgrade" and the installation is completed and the Pi rebooted. I don't modify anything in "Network settings" and Target info=BCM2835, OS Version=11.1 and Internet access is confirmed.


Then, when I click on "Launch Example" the project appears but no connection is possible.


So, in brief a communication is established during the Hobbyist "Target configuration" but connection fails when the sample project appears.


Thanks in advance for any ideas,



0 Kudos
Message 9 of 11


I have created a this post as I discovered that the problem was related specifically to Labview CE 2021 version. The same steps in Labview CE 2020 work fine.


0 Kudos
Message 10 of 11