Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

LINX for Labview 2021 Error 5003 with Error 5007 with loop rate 4294967295

I am using Arduino UNO with LINX on LabVIEW 2021. During 2 years I do not have a problem. The last 2 months I do not use Arduino UNO. The connection is via USB. Now I am using again it does not work, but I do not understand why. There are 2 errors have appeared. When I stopped the code quickly first error appears which is 5007 which says this:


“Open Serial.vi >>

Initialize.vi >>

Initialize Device.vi >>

Check Firmware Version.vi

Possible reason(s):

The selected device is currently using firmware version 9.0.0 but the LabVIEW API is version 3.0.0 Please use the firmware wizard (Tools>>MakerHub>>LINX>>Firmware Wizard) to update the device firmware.”


Ok, I don't understand why, this computer has not been connected to the Internet all this year, it is very unlikely to have a problem like this. However, I have installed LINX again on Arduino without internet. I did the test with the PIN13 LED and it works, the Arduino receives the signal and turns the LED on and off. But, the error 5003 appears after a few seconds with a loop rate of 4294967295:


“Error 5003 occurred at :


Open Serial.vi >>

Initialize.vi >>

Initialize Device.vi >>



Possible reason(s):


LabVIEW was unable to connect to the LINX device using the following settings: 


Interface: Serial

COM Port: COM3


Please make sure that the LINX firmware is loaded on the device (Tools>>MakerHub >>LINX>>Firmware Wizard)  that there are no other open connections to the device, then check the configuration settings, and try again.


If this error persists please search, then post on the LINX forums at www.labviewmakerhub.com/forums/linx


I do not understand how the computer can communicate with Arduino to send a signal to LED of PIN13 and at the same time, there are not a good communication. Also, in the case that I run any code for enough time, the error 5003 will appear instead the 5007 error, but in this case, it is the time when I click on the stop button.

I don't know if the Arduino is broken, as I have working to close inside a box with other boards. Maybe I broke it with too much movement.


Also, I tried this solution and doesn’t works https://forums.ni.com/t5/Hobbyist-Toolkit/Linx-for-Labview-2020-Error-5003/m-p/4177138#M921:

“There is a bug in the Hobbyist Toolkit. Replace C:\Program Files (x86)\National Instruments\LabVIEW 2021\vi.lib\MakerHub\LINX\Private\Device\Utilities\Packet Number.vi with the version attached.“


0 Kudos
Message 1 of 1