Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

Linx for Labview 2023Q3 Error 5003



Using the LINX toolbox with ardurino with Labview comminuty 2023Q1 was producing the following error:


"Error 5003 occurred at ......LabVIEW was unable to connect to the LINX"

A search uncovered many solutions, but none had worked until I found this one from 2021.
"There is a bug in the Hobbyist Toolkit. Replace C:\Program Files (x86)\National Instruments\LabVIEW 2021\vi.lib\MakerHub\LINX\Private\Device\Utilities\Packet Number.vi with the version attached. 
I replaced the listed file and everything worked great.
But then I just ugraded to Labview 2023 Q3 yesterday and see the original issue reappear.
Labview 2023 Q3 apparently still has the same buggy file that reloaded over the fixed one.
After replacing that file a second time it is now working.
I think NI needs to make this simple correction to future releases of Labview.
0 Kudos
Message 1 of 2

For reference, the OP is apparently talking about this post for the solution. (links to quoted sources are important!)


0 Kudos
Message 2 of 2