FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Using A Mark I FRC 8 Slot cRIO Without FRC Image

Hi, I am a member of FRC robotics team 3451, and was hoping for some help.  We have two FRC 8 Slot cRIO devices, that we would like to put to use in our pre-engineering class.  However, we want to be able to use that hardware like it would be in industry.  That being said, what are the steps we would need to go about to create a labview program, that can interface with the NI 9201, NI 9403, and NI 9472, and then build and deploy it to the cRIO? Any help would be appreciated, and thanks in advance.

0 Kudos
Message 1 of 5
(4,908 Views)

To do this you would need LabVIEW FPGA installed and licensed in your pre-engineering lab. You would then write and deploy an FPGA VI that uses IO Nodes to expose the I/O of those modules to the main VI's front panel. You can then access the FPGA from panel from a LabVIEW RT application using the FPGA Host Interface VIs in the RT palette.

0 Kudos
Message 2 of 5
(3,068 Views)

Do you know if the FPGA add-in is included in the labview for frc package? If not is there a student license we can get for the package. Thank you!

0 Kudos
Message 3 of 5
(3,068 Views)

It is not part of the FRC software.

I know there are acedemic site licenses for FPGA. That's what would be appropriate for your lab. Student licenses are for student-owned computers.

0 Kudos
Message 4 of 5
(3,068 Views)

They're probably better off working with the site license for the RT Module versus the FPGA Module.  For something that would be in a pre-engineering lab, I'd expect they'd want to work with the Scan Engine and make codes in the RT code that interface with the I/O and let the scan engine abstract away how the I/O is grabbed.  Using the FPGA to work with the I/O is more for if they want to process the I/O on the FPGA itself.

The lab computers will need the following to work with cRIOs:
LabVIEW

The compatible LabVIEW RT Module

The compatible NI-RIO drivers

(Optional) The compatible LabVIEW FPGA Module

The compatible version generally is the same year as the LabVIEW version you have installed.

0 Kudos
Message 5 of 5
(3,068 Views)