FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Active Framwork - Problems Deploying Code trying to run Robot Main

We use the Actor Framework this year for FRC (LabView 2014). While trying to debug code by running Robot Main with the roboRio, LabView frequently reports a problem trying to deploy Actor VIs and stops deploying VIs. If you just keep trying to Run Robot Main, sometimes it will complete the deploy and other times it will crash LabView. Any VI that the deploy dies on doesn't show any errors when you just pull up the VI and sometimes the errors are with Actor Framework VIs in the library that haven't been changed. It can take half a dozen or more attempts to run Robot Main to get to a state of being able to debug.

We have learned that we seem to have more success if we disable the Startup.exe and reboot the Rio. Once LabView is happy with being able to run Robot Main, it seems to work fine until new code is compiled and deployed.  In all cases, there are never any obvious reported problems with the VIs that deployment pukes on in the Error List.  I can compile and "Run as Startup" the exact same code without LabView thinking the same VIs have errors. If there are problems with the VIs, LabView doesn't show me the errors in the Error List.

Are there any known problems trying to deploy code by running Robot Main when using the Actor Framework?

Are there other log files I can look at to try to determine why LabView thinks there is a problem with a VI that it doesn't want to deploy.

Are there any tricks with getting LabView to have a better chance at deploying code when running Robot Main to debug apps?  I can't figure out the special sauce to get LabView or the roboRioo happy to allow me to debug VIs. Of course this always happens at the worst time when trying to debug a bit of code before the next round.

0 Kudos
Message 1 of 7

Hey there, just wanted to know that we taking a look into this. Which Actor Framework VIs fail to deploy? Is it the Actor, Message, or Last Ack VIs?

Are there certain situations where the project always fails to deploy, or always successfully deploys? If so, could you describe those situations in more detail?

You may want to check out this thread as well:


Daniel C.
Applications Engineer
National Instruments
0 Kudos
Message 2 of 7

Usually its an Actor Core of one my Actors. Sometimes it is Launch itself (which I haven't touched). I think I have seen in on s in message as well. I have not seen Lask Ack fail to deploy (I do not override Last Ack in my code).

I wish I could describe a repro. My most recent example above was when we had been running a Startup exe for a while but then I wanted to debug some new code. I tried 7 or 8 times to Run Robot Main and it just keep complaining about different VIs not deploying with a couple of LabView crashes thrown in (Access Violiation - C5s).

I haven't seen problems when doing a "Run as Startup" which also deploys VIs.

When the problems occur, it is when I am trying to Run a VI from LabView. It has occured when I run other VIs than Robot Main (I have some Unit Tests VIs I roun) . When I do get the "Failed to deploy", I seem to get the problem several times in a row, usually with different VIs failing to deploy on future attempts, but then once the deploy is successfull, it seems to be fine from then on for hours .

It feels like something with files being held open on the roboRio causing LabView to be unhappy.

Are there some log files I can collect for you guys when this occurs next?  I am hoping there is some log file that has detailed errors either on LabView or on the roboRio that reports a real error when deploying the VIs.

0 Kudos
Message 3 of 7

Still can't predict when this will occur. And still don't know how to resolve it except for re-load LabView and try again.

The VIs reported to fail to deploy varry. Sometimes Actor Core, sometimes, sometimes other VIs. By far it seems to have problems on Actor Framework VIs and just not other Class VIs.

When I get a problem with deployment, sometimes I can just close LabView and then reopen the project, and then run my VI that I want to debug. If the deployment fails a second time, it always points to yet a different VI.

Tonight I tried to close LabView, and then reset the roboRIO to try to "start clean" but it still reported a problem trying to delpoy VIs, I closed out a LabView and tried to run Robot again, and it successfully finished the VI.

I have noticed when I reload my project after a failed deploy, that VIs I haven't touched do Compiles, even Actor Framework library VIs. It seems that LabView thinks some VIs are "dirty" and wants to re-compile. Not sure if this is related or not.

Very, very frustrating. I don't mind fix errors that are reported, but when errors are reported that don't seem to exist, I am not sure what to do about that.

0 Kudos
Message 4 of 7

How do I attached code to this discussion? Do I need to start a new discussion?

0 Kudos
Message 5 of 7

Hit reply.

Hit use advanced editor.

At the bottom you'll see an option to attach files

0 Kudos
Message 6 of 7

Got an error that project is too big to upload. This isn't something where I can crop out "example code" as the issue appears to be something with the project as a whole.

Is there another way I can get my project to you?

0 Kudos
Message 7 of 7