FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Imaging problem with NI Robotics CRIO

Imaging problem with NI Robotics CRIO

Our robotics team just bought a NIRock kit from Andy Mark and the NI control system that comes with Labview 8.6.1 (2010 version),and the NI cRio 9074.

We have experienced FRC people in the team but we are having a problem with the cRio that we cannot find a solution for.

I have installed the software from the kit, which come with the CompactRio Imaging tool version 2009.12.11.00 and the image

I have followed all the instructions I could find on the web and available documents to set the system up. The team number was set, the IP of my development laptop was set to 10.xx.yy.6, with mask (also tried to use, with no change in the behavior), no DNS, or gateway was specified.

I have also updated the information in my computer to the lastest versions from the NI website for the last FRC competition. Thus, I have also the the FRC CompactRio Imaging Tool 2012.1.20 installed in my laptop.

The laptop was connected to the cRio using a cross-wired ethernet cable.

Just to eliminate any doubt about my network settings, I was able to ping the cRio with the IP 10.xx.yy.2.

These are the scenarios I went through without being able to get to a successful installation:

scenario 1. Using the CompactRio Imaging tool version 2009.12.11.00 and image

1.a: safe mode on: the tools asks to format the controller and I use the option to continue. The tool freezes. It looks like there is some communication going on at the beginning but I have waited for 1 hour without any feedback from the tool. The status led is blinking 3 times, showing that the software is corrupt.

1.b: safe mode off: the connection with the CRio is established, but there is an error when I try to load the The error message is:

The specified IP address is unreachable. Ensure that the IP address is on the correct subnet.

Why do I get such a message if the cRio is accessible, and was found by the imaging tool in the first place?

I have searched for this error on the web, and there is information on Chief Delphi, and a LOT of messages that do not lead me to the solution of my problem. There are tons of suggestions of steps to follow, and I have tried many of them, and didn't go anywhere.

scenario 2. Tried to go out of the basic sofware that come with the kit. I have used the CompactRio Imaging tool version 2009.12.11.00, and the image

This imaging process worked just fine. No errors. When I try to use labview, then comes the error. The sofware in this image is not compatible with Labview 8.6.1. Another dead-end. The error messages on labview say that the realtime sofware in the cRio is not compatible.

scenario 3: Kind of desperate measure, used the CompactRio Imaging tool version 2009.12.11.00 to download the image

In this case I get an error:

Unable to complete operation because of unexpected error:

Error 7 occurred at File/Directory Info in>ConfigUtility.lvlibSmiley Very

Possible reason(s):

LabVIEW:  File not found. The file might have been moved or deleted, or the file path might be incorrectly formatted for the operating system. For example, use \ as path separators on Windows, : on Mac OS X, and / on Linux. Verify that the path is correct using the command prompt or file explorer.


In summary, I have tried to cover the obvious problems, and used many suggestions I found from the web, and I all my experiments are leading to a cRio that does not work.

Please, help me solve this problem.

0 Kudos
Message 1 of 2

Re: Imaging problem with NI Robotics CRIO

Hey Tenca,

scenario 1: If you take the FIRST software out of the equation and just use Measurement and Automation Explorer are you able to format the controller and install LabVIEW Real Time (  I can't say I have seen the freeze while in safe mode before.  When you are not in safe mode are you prompted to enter safe mode before formatting?  Are you an active FIRST team (i.e. is upgrading to the latest LabVIEW FRC version an option)?

scenario 2: The errors you get here are expected and make sense.  You can't use the newer image with the older version of LabVIEW.

scenario 3: Is this the same as scenario 1 just with different errors?

Product Support Engineer
National Instruments
0 Kudos
Message 2 of 2