SystemLink Forum

Showing results for 
Search instead for 
Did you mean: 

Getting Error when Publishing the Package with include dependencies

Using LabVIEW 2021 Sp1

NI Package Manager-23.0

System link Server -2020R4.3(Remote)


Test connection to server successful.

Publishing the package also works from project builder UnChecking the include all dependencies in systemlink feed.

If include all dependencies in systemlink feed is selected then only getting this error. 

Build-Publish error.png


After enabling the error log for NI Package Manager this is what found:

Additional error information:
-125105: Package 'eula-ni-standard:windows_x64=' is not installed.
File: source\nipkg_client\pkgclient\SolverTransaction.cpp
Line number: 697
===== 2023-Feb-23 18:14:36.100268 =====
Exception in ni::pkgclient::TransactionBase::StartInternal. Error code: -125067
Request type: 26
-125067: The requested transaction cannot be solved. 1 problems were found.
File: source\nipkg_client\pkgclient\SolverTransaction.cpp
Line number: 651


Tried to install this package via NI Package Manager but it is disabled:



Any help is appreciated.

0 Kudos
Message 1 of 17

uday, it might be helpful to post the NI Package Manager log file created when you hit this error. You can find the corresponding log file in the following directory: %localappdata%\National Instruments\NI Package Manager\Logs\NIPkgLogs\. The file will be of this format: NIPkgLog*.txt.

Scott Richardson
0 Kudos
Message 2 of 17

Thanks for the reply.

Please find attached file as requested. Did repair/reinstall already. After that did reset windows and installed all packages still this error is coming.

0 Kudos
Message 3 of 17

uday, EULA package are not installed so that is why it is dimmed in the Packages tab. EULAs are instead added to the C:\ProgramData\National Instruments\NI Package Manager\eulas\ directory after they are displayed, and that is where NIPM looks for them when performing various operations.


Can you see if that directory contains the file eula-ni-standard_23.0.0.49223-0+f71_windows_x64.nipkg?


If you can locate this package and add it to that directory, does that mitigate the error?

Scott Richardson
0 Kudos
Message 4 of 17

The eula package already exists in the directory.


0 Kudos
Message 5 of 17
Can Anyone help in this?
0 Kudos
Message 6 of 17

Uday, in your image, I see that there are two eula-ni-standard packages in the directory, and there is a Packages and and Packages - Copy file in that directory. The directory is actually a built feed, so the Packages* files defines what is in the feed. The Packages file is only created for ease for users to review, but the Packages.gz file is what really defined the contents of the feed.


Since there is a *Copy file, I am assuming that you were trying to mitigate the error by editing the Packages file, which will not do anything. If you need to manually add EULA files to that directory, you must add the files and then use the nipkg.exe feed-add-pkg command to add a new package to the feed list, or use nipkg.exe feed-create to recreate the entire feed with all packages in the feed directory. Neither of these commands copy the package to the feeds directory.



  1. Can you post a zip file of all those files in that EULA directory so that we can review them?
  2. Can you build a feed or installer locally with LabVIEW that includes dependencies, and can you share the Packages file that it creates so that we can review it?
Scott Richardson
0 Kudos
Message 7 of 17

Hi Scott,

1)attaching the entire eulas directory for reference.

2)Could you explain bit more on the 2nd question?


Also tried manually installing the eula-ni-standard_23.0.0.49223-0+f71_windows_x64 package and it says conflict with ni package manager tried with older version and encountered the similar error. Why does it conflict? and i think this could be the reason why iam unable to install the eulas from ni package manager.

eula-install conflict with ni package manager.pngeula-install older version conflict with ni package manager.png

0 Kudos
Message 8 of 17

uday, looking at the you posted, although the EULA files are in that directory, the EULA files are NOT listed in the feed files (Packages.*). These files include the following:

  • Packages: user-friendly that contains the feed list of packages. NIPM does not read this file.
  • Packages.gz: a compressed file that contains the above Packages files. This is what NIPM reads.
  • Packages.stamps: a file with signature information about the packages that the feed points to. NIPM reads this to validate the packages before using them.

Since the packages are not listed in the feed, NIPM does not know the eula-ni-standard file is on disk. I have attached replacement feed files that should make fix this feed and NIPM will find the eula-ni-standard file.


When NIPM finds a EULA attribute in a package it is installing, NIPM displays the EULA during installation, and it adds the file to the C:\ProgramData\National Instruments\NI Package Manager\eula\ directory and then effectively uses nipkg.exe create-feed command to update the feed files. That is what I did manually to update those files. 


Lets ignore question 2 for now and see if the update feed fixes the problem.


Part of the reason that EULA files are handled differently than dependencies is that EULA file contents need to be displayed before installing a package, and as such we do not want EULA files to be installed like normal packages; hence the conflict with NIPM itself. NIPM has separate logic to handle them differently.

Scott Richardson
0 Kudos
Message 9 of 17

Scott Richardson, thanks for the follow up so far.

-I've updated the eulas folder with the given files in attachment.

-Tried to install from NI Package manager still those are greyed out.

-Did "C:\Program Files\National Instruments\NI Package Manager\nipkg.exe" feed-update to see if it has any impact still same.

-All the eula packages which has conflict with NI Package Manager are greyed out and unable to install.

-Is there a way to bypass this conflict condition and check if it installs? I guess because it is made as conflict NI Package manager not allowing it to install.

Let me know if further information is required.

0 Kudos
Message 10 of 17