From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

SignalExpress

cancel
Showing results for 
Search instead for 
Did you mean: 

Code Generation Error

I have Labview Development Professional 2016 and the included SignalExpress 2015. I am unable to generate code from signal express for any project. The error is:

 

"The version of LabVIEW you are generating code into does not contain all the necessary SignalExpress support files. Make sure you launch the version of LabVIEW with SignalExpress support installed before generating code from SignalExpress. If you installed this version of LabVIEW after SignalExpress just re-run the SignalExpress installer to install the necessary support files."

 

I have tried to do as others suggested by downloading and reinstalling SignalExpress - with no luck.

 

Any other suggestions?

0 Kudos
Message 1 of 4
(4,648 Views)

Hey,

 

So I have a few thoughts on this. SignalExpress 2015 has some limitations listed in this document.

http://www.ni.com/product-documentation/52689/en/

One limitation that could be causing you problems is if you are running 64 bit LabVIEW, SignalExpress will not generate code. 

 

As for next troubleshooting steps if you are not using 64 bit LabVIEW would be to try a repair of the SignalExpress software or doing a Force Reinstall

 

Repair NI Software Link:

http://digital.ni.com/public.nsf/allkb/AC6ED75D3D93375686256E8E00245F0D

 

Force Reinstall NI Software Link:

http://digital.ni.com/public.nsf/allkb/ADD22E807D5A12AD862579EC00760F79

 

Please do the force reinstall after trying all of the other troubleshooting, as this is the most involved process. Hope this helps!

 

Spencer R | Applications Engineer | NI

0 Kudos
Message 2 of 4
(4,624 Views)

Though I am running the 64 bit version of Windows 7, I do have the 32 bit version of Labview.

 

Neither the repair nor the forced reinstall has solved the issue. I can't think of anything in the projects themselves that could be causing this as the tutorial project for exporting code also fails to export its code.

0 Kudos
Message 3 of 4
(4,601 Views)

Perhaps there was an error when installing LabVIEW 2016? Maybe the support files were not included. You may want to try doing a force reinstall of your LabVIEW version. Perhaps that will help fix the support files for Signal Express. Good luck!

0 Kudos
Message 4 of 4
(4,569 Views)