NI TestStand

Showing results for 
Search instead for 
Did you mean: 

Running sequence programatically

Go to solution



I am finding a problem in running sequence file programatically. I referred the example VI (C:\Users\Public\Documents\National Instruments\TestStand 2014 (32-bit)\Examples\TestStand API\Executing Sequences Using API\LabVIEW) shipped with TS2014 that runs the sequence through sequence context by invoking TSEngine so the inputs to the VI are seqeunce context, sequence file, process model.

To make my task easier I modified the attached code to make it standalone by running the sequence through TSEngine directly so the inputs to the VI are sequence file, and process model.


it works fine when i run as VI but doesn't work when converted into exe.


Please let me know if I am doing something wrong or missing something

Thanks in Advance



0 Kudos
Message 1 of 3
Accepted by topic author vivekkde

You should look into creating a UI is you want to run your sequence programatically. The UI can be hidden so it functions the same as your code is expected.Start with the simple UI "C:\Program Files (x86)\National Instruments\TestStand 2014\UserInterfaces\Simple\LabVIEW" so see how this can be done.


Specifically. a person doesn't open a reference to engine. What's much more common is someone placing an Application Manager control, call Start method. and then get the reference to engine from there. Be sure to shutdown the application afterward and close the extra references. I'm assuming that because you're in a development enviroment is the reason your code works as a VI.


"I won't be wronged. I won't be insulted. I won't be laid a-hand on. I don't do these things to other people, and I require the same from them." John Bernard Books

Message 2 of 3

Hi bsvare.

It worked for me. Thanks alot. But i didn't use entire references. Got Engine ref from application manager worked for me.


0 Kudos
Message 3 of 3