NI TestStand

cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

Ethernet-Connectivity-Problem

Hello Everybody and greetings from germany πŸ™‹β€β™‚οΈ

 

as part of my education, to become a  certified technician in a several month, unfortunately I do have some problems with my final thesis.
The project is an existing test stand which contains a NI PXIe-8840 Quadcore Engine  controlling a DC-Powersupply(Delta Elektronika) and a DC-Load Assembly(Chroma). The devices are connected and corresponding by ethernet.
Furthermore, the systems includes a simpel Windows PC which contain" LabView 2017" to setup and run the specific testprograms and also to connect the test stand to the local network(intranet).
All devices are connected  to a switch by ethernet cable. 

Here is a description of my current problem:
When I power on my system, the PXI and the Windows PC are normally booting up. 
Subsequently, I do start NI Max Application to check if the connection between the devices is okay and here is exactly the failure!

Ni Max can not find the PXI-Controller! As part of a emergeny solution it is possible to "awake" the PXI-Conroller by switching the PXI off. Then I disconnect the ethernet cable  from the Win-PC and PXI-Controller towards the switch. Afterwards, I establish a directly connection between the Win-PC and the PXI and reset(restart) PXI again. Right from the outsight you can recognize the PXI is kind of awake now because the led's at the ethernet port are flashing! 
Now, it is possible to reconnect the Win-PC and PXI-Controller to the switch-device and restart the Win-PC.
After the Win-PC has finished its booting process and I execute another checkup with NI-Max again, my  test stand is ready to go. 

I have already tried out a several boot up sequences between the devices but nothing at all filled the gap!
Every device has its own IP-adress and the setup of the network-adjustment is DCHP.
I really hope, that anybody outthere could help me out with that!
Many thanks in advance and wishing you all a happy and peacefull new year! πŸŽ‰πŸ₯‚πŸ€

Kind Regards
Andy

 

 

 

0 Kudos
Message 1 of 3
(639 Views)

Hello Robofoot76,

 

I hope you enjoyed your Christmas holiday!

 

Do you use Phar Lap OS?

If yes, did you see this article? Provisioning a PXIe Controller to the NI Linux Real-Time Operating System - National Instruments

 

Best regards.

0 Kudos
Message 2 of 3
(562 Views)

Dear Edgar,

I had such a good time with the ones I love, thanks for asking an I really hope that you had a pleasant time as well?
I don't think that the system runs on Phar Lab OS? Would it be a benefit  to install Phar Lab OS and how I can I find out If it's already installed.
I'll be back in front of my project by the end of next week.

Thanks again for your supportπŸ‘
cheers

Andy

0 Kudos
Message 3 of 3
(519 Views)