NI Linux Real-Time Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Impossible to rebuild NI out-of-tree Drivers with DKMS

Solved!
Go to solution

Using latest toolchains for Linux (Descargar Herramientas de Compilación GNU C y C++ x64 - NI), we've compiled kernel from source ni/linux at nilrt/23.0/5.15 (github.com) for using it on:

 

ID=nilrt
NAME="NI Linux Real-Time"
VERSION="9.2 (hardknott)"
VERSION_ID=9.2
PRETTY_NAME="NI Linux Real-Time 9.2 (hardknott)"
DISTRO_CODENAME="hardknott"
BUILD_ID="23.0.0f158-x64"
VERSION_CODENAME="hardknott"

 

When trying to build NI drivers following this guide: nilrt/README.kernel.md at nilrt/master/hardknott · ni/nilrt (github.com) 

We get this error:

 

admin@NI-cRIO-9045-01F88633:/lib/modules/5.15.79-rt54-g89099fc8ce17/build# make prepare                                                                                                                                                  SYNC    include/config/auto.conf.cmd
scripts/kconfig/conf: /lib/libc.so.6: version `GLIBC_2.34' not found (required by scripts/kconfig/conf)
make[2]: *** [scripts/kconfig/Makefile:77: syncconfig] Error 1
make[1]: *** [Makefile:620: syncconfig] Error 2
make: *** [Makefile:740: include/config/auto.conf.cmd] Error 2

 

Our build host is Ubuntu 22.04.

0 Kudos
Message 1 of 2
(821 Views)
Solution
Accepted by topic author juliovs

Solved using Ubuntu 20.04 because Ubuntu 22.04 is using glibc 2.34/35

0 Kudos
Message 2 of 2
(756 Views)