LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

problem with connection between GPIB and Labview (LV2016 and Keysight IO)

Hello,

 

I installed the LV2016 on my computer and use a Agilent 82357B GPIB-USB. I followed all the articles to make Keysight IO v18 connect with MAX, and it works. However, the problem is that even I can see all the information on the MAX and I can even send the commend to the instrument, and that works, but it still seems that my labview program is disconnected to the instruments...(I'm pretty sure the simple program is fine, and at least works fine on another computer with the same setup with LV2011 and Keysight IO v16)

Can anyone tell me what can I do?

Appreciated!

Yen-Po

0 Kudos
Message 1 of 11
(3,185 Views)

Hmm -- I always try to keep my Drivers at the same Version as LabVIEW, but you are using LabVIEW 2016 with the LabVIEW 2017 488.2 drivers.  Could that be a problem?

 

Bob Schor

0 Kudos
Message 2 of 11
(3,146 Views)

Hmm -- I always try to keep my Drivers at the same Version as LabVIEW, but you are using LabVIEW 2016 with the LabVIEW 2017 488.2 drivers.  Could that be a problem?

 

Bob Schor

 

P.S. -- we could be a lot more helpful if you posted your VI ...

0 Kudos
Message 3 of 11
(3,146 Views)

Dear Bob,

 

Thank you for the kind reply. I checked the drivers on NI website (http://search.ni.com/nisearch/app/main/p/bot/no/ap/tech/lang/sv/pg/3/sn/catnav:du,n8:3.25.123.785,ss...), and I think NI-488,2 17version is the only one fits my win 10 computer on this website. Can I find other resource for 2016 version somewhere?

Furthermore, I just want to manage the Keithley 2400. The picture shows my VI below.

Yen-Po

Download All
0 Kudos
Message 4 of 11
(3,139 Views)

Try doing a search on Support.ni.com for NI Device Driver 2016.  I found what looks like the 2016 Driver DVD for download.  Note that you cannot install an earlier version (2016 Drivers) "on top of" a more recent one, so you have to (at a minimum) remove the 2017 Drivers.  In my experience, the safest thing to do is to remove all NI software and do a re-install of everything from the beginning.

 

Bob Schor

0 Kudos
Message 5 of 11
(3,130 Views)

@Yen-Po wrote:

Hello,

 

I installed the LV2016 on my computer and use a Agilent 82357B GPIB-USB. 

Appreciated!

Yen-Po


 

For Agilent/Keysight USB-GPIB you need to enable the NI-VISA Passport for TULIP (it is disabled by default)

 

Open NI MAX

Navigate to Tools---->NI VISA---->VISA Options

Select Passports from the tree

Check the box to enable NiVisaTulip.dll -- NI-VISA Passport fo Tulip

tlipCapture.PNG

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 6 of 11
(3,125 Views)

You mention wanting to control a Keithley 2400.  A few comments..

 

1) Make sure that the Keithley 2400 is set to receive SPCI commands.  (That's what you are sending to it in the image shown.)  Its a setting in the menu from the front panel.

 

2) Your image suggests that you are sending a "SOUR:VOLT" command with a comma "," in it.  That's not a good thing.  That will cause an error. You may need to look at your Windows regional settings to prevent that.  You want to send 1000.00 and not 1,000.00 or the instrument will generate an error.

 

3) The Keithley 2400 has a fine set of LabVIEW drivers you can use to write your code.  Why download those as a starting point.  You need to make sure NI VISA is installed to use these.  http://sine.ni.com/apps/utf8/niid_web_display.download_page?p_id_guid=25B255F3AA83660EE0440003BA7CCD...

 

Post code if you get stuck.

Craig

0 Kudos
Message 7 of 11
(3,117 Views)

Hello,

 

Thank you for this information. In fact, I checked it first time when I saw other's problem, so it means that I still have problem for it...

0 Kudos
Message 8 of 11
(3,071 Views)

Thanks very much. I did, but still doesn't work...

0 Kudos
Message 9 of 11
(3,037 Views)

I tried to uninstal all 2017 suites and components, and install 2016 driver. However, it didn't goes smoothly, so I upgrate everything into 2017 version, including labview 2017! However, the problem is still there.

I can communicate with Keithley 2401 by NI-MAX now, but not Labview. Even if I tried examples, I can't choose the GPIB visa number... as shown in fig.

Best regards,
Yen-Po

Download All
0 Kudos
Message 10 of 11
(3,036 Views)