LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

pda problems

To anyone who can help!

I am on the verge of throwing everything out the window!
What I am trying to do is use my PDA as a data acquisition device. What I need it to do is read data from serial ports. To do this I am using the serial example in the PDA folder of the comms file in labview8.0.
My problem is in trying to get the VI to run on the PDA. I have only ever succeeded in doing this twice. For some reason it will not work twice in a row, and also not if I repair all the software that I use (activesynch, embedded and the SDK).
What I have done is create the project in the explorer window and I made all the build applications and like I said it all worked perfectly twice and I cant understand why this is. Is there some ports or something that I have to close up after use in order to redeploy? Does anyone have any experience in this? I have installed all the necessary software and not just that but I have also uninstalled and reinstalled everything!!

Help!
0 Kudos
Message 1 of 6
(2,504 Views)
I've used an IPAQ h5550 to acquire data from a serial port without problem.
 
Are you receiving any error messages?
 
If you post your code I can take a look at it.
 
Good Luck
Eric
0 Kudos
Message 2 of 6
(2,501 Views)
Hi Eric,

I am just using the project that is in the examples for labview8.0. I got it from National Instruments/Examples/PDA/Pocket PC/Comms/Serial.
I have attached it here. I have made no alterations to it as yet because I just want to get it working!
Let me know if it works for oyu. And if it does, will you try and see if yo can get it working twice in a row. Like I said, it workied jst a few hours ago (I ran the serial VI for the Pocket PC device, yo will see it in the project). However it was too big for the PDA screen so I coldnt use some of the front panel controls. I "exed" out of it on the PDA and then when I tried to run it onto the PDA a second time it just gave an error!

Hope you can help!
0 Kudos
Message 3 of 6
(2,490 Views)

What kind of errors are you seeing?

Are you talking about build errors or application errors.

If you did not use the close button on the front panel the application is still running on Windows CE.

If you go to Settings>System>Memory>Running Programs, you can see which applications you still have running and stop them if nessecary.

Unfortunatly, I don't have a lot of time to test the software but I can help if you need to undersand the error codes.

Eric

0 Kudos
Message 4 of 6
(2,482 Views)
Hi Eric,

Thanks for the speedy reply!
I have just retried the whole process and I am still getting an unrecognosable (by Labview) error. I have also checked the memory of the PDA and the only program running right now is the ctive sync! anyway, I have just read another guys post who had the same problem as myself and he reckons he solved it by uninstalling (which had earlier proved unsuccessfull) but this time he found some PDA file in the directory that had not been deleted the last time so when he deleted those and reinstalled again it worked! I will try this and hope that it will work! Wont know untill next week as I need to get a hold of the technicians in college to get labview for reinstalation.
I also have another quick question, can you use the write to measurement file in the PDA module? I will attach the VI that I will be rewriting if I can get this to work. However I am running out of project time so I may have to forget it altogether! If I cant get it to work I will just be using the laptop as a data acquisition unit.

Cheers,

Emer
0 Kudos
Message 5 of 6
(2,478 Views)
I hope you can get your PDA Module working.  If you are using PDA Module 8.0 you can not use the VISA subvi.  You will have to replace them with the serial compatiblity VIs.
 
You won't be able to run you PC example directly on the PDA.
 
I don't know how fast your data is going to be coming out but you might think about using a producer consumer architecture for processing your data.  It seems like you should be able to parse your string in one loop instead of three to simplify your code.  If you post an example of the output string someone can help you parse it very easily.
 
I don't think I would recomend using the write to measurement file VI.  Your better off using primatives with the PDA module.  Not everything is supported for the PDA and you can format you data easier with the primatives.
 
Good Luck
Eric
0 Kudos
Message 6 of 6
(2,469 Views)