LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

missing objects - block diagram

Hello!

So... My program it's working fine, but it seems that I cannot see some objects in the block diagram (see the attached image), even if they're working fine. do you know how to show them? because I would like to change something and I don't know how to do that!

I've seen also that if I try to run the clean up diagram function for the whole program labview crashes!

I'm working with labview 2010.

 

thanks!

 

bye!

0 Kudos
Message 1 of 16
(2,872 Views)

You have not attached any image if you can attach then it would be helpful

-----

The best solution is the one you find it by yourself
0 Kudos
Message 2 of 16
(2,865 Views)

I'm sorry, I forgot to attach the file! Here in this image you can see how it appears (left) and how it should be (right)!

 

Thanks!

 

Bye!

0 Kudos
Message 3 of 16
(2,861 Views)

Try an Auto Cleanup (ctrl+u) and see if it helps. You can select an area and only have that one cleaned.

/Y 

G# - Award winning reference based OOP for LV, for free! - Qestit VIPM GitHub

Qestit Systems
Certified-LabVIEW-Developer
0 Kudos
Message 4 of 16
(2,859 Views)

I've already tryed that, but it doesn't help. if I do that just for the structure that you can see in the image nothing happens, if I do that for the whole program labview crashes.

 

bye!

0 Kudos
Message 5 of 16
(2,856 Views)

In this can you show where is the missing object you mentioned?

-----

The best solution is the one you find it by yourself
0 Kudos
Message 6 of 16
(2,850 Views)

I'm sorry I haven't understood, what do you mean? 

However, as I said before, on your left you can see how the structure appears, and on your right you can see how it should be (so you can see all the controls and the indicators that are hidden in the structure on the left)!

 

Thanks!

 

Bye!

0 Kudos
Message 7 of 16
(2,847 Views)

Dbl-clicking on the missing controls on the front panel should highlight them on the block diagram.  Also, is it possible that your code is underneath the sequence structure?  Try moving the structure down to see if that is the case.

0 Kudos
Message 8 of 16
(2,840 Views)

I've tried that, but I doesn't work. If I double-click them it will show just a dashed line, with nothing inside, and once that they're selected I cannot right-click on them or move or anything. and no, the code it's in the structure, not under!

 

Thanks!

 

Bye!

0 Kudos
Message 9 of 16
(2,837 Views)

I guess that is just an image pasted in the Block diagram (Left side one) and thats why your program is running without any problem.

-----

The best solution is the one you find it by yourself
0 Kudos
Message 10 of 16
(2,835 Views)