LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

labview current measurement error using ni 9207 with cDAQ 9174

Solved!
Go to solution

hi I wanna measure 4-20ma current for flow rate using ni 9207 but when I measured, current graph was ploted  constant function 

graph2.png

 like above graph 

1. plz tell me what is wrong why current is over the 20mA and it did not fluctuate  attached my block diagram 

block diagram.png

2. in the task making section there is external resistance what does that mean? I just connected ni 9207 and 4-20mA port 

1.jpg

2.jpg

this connection is wrong? how can I know the resistance 

스크린샷 2024-05-23 16.32.18.png

this is circuit which I use

the main problem is current did not be measured 

I wanna measure the values plz tell me the solution 

if u need more information plz tell me 

0 Kudos
Message 1 of 5
(243 Views)
Solution
Accepted by topic author songsari

You connect the current signal to AI0+ and AI0- on the 9207. This is a voltage input. The current input is AI8 and you need to connect the current output between VSup (positive power supply voltage 12V or 24V depending on your sensor) and the AI8 input. And of course read the AI8 input in DAQmx.

Rolf Kalbermatter
My Blog
Message 2 of 5
(228 Views)

holy I really appreciate it i don't know why I connected voltage hole 

And could I ask u 1 more. what is external resistance in current task making section

flow meter device circuit resistance or should I connect another resistor?

0 Kudos
Message 3 of 5
(188 Views)

The current measurement resistor is internal to the module and you do not have to do anything external in terms of a resistor. The documented input impedance for these channels is 85 Ohm.

Rolf Kalbermatter
My Blog
0 Kudos
Message 4 of 5
(183 Views)

thank u so much I solved my problems 

0 Kudos
Message 5 of 5
(146 Views)