Showing results for 
Search instead for 
Did you mean: 

error with excel_save_workbook

Go to solution

i am currently trying to create an executable and I am getting an error that i have printscreened and attached.  Im not sure what the problem is or how to fix it.  The document that can't be saved must be imbedded in one of the vi's i used in my output to excel.  Any Ideas?



error message


VI that is having the error

Download All
0 Kudos
Message 1 of 8

Excel_Save_Workbook is a VI that is part of the Report Generation Toolkit (which must be purchased, so I don't think it's not legal to post VIs from these toolkits). Did you create your own?


Are you using the original LabVIEW 2009, or a patched version? The f2 patch fixed an issue with error code 1502 being generated during some builds.

0 Kudos
Message 2 of 8

I am using Labview 2009 and no i didn't create my own I used the ones supplied with Labview.  I was able to open the Excel_Save_Workbook VI and simply remove the node that was causing that VI to not be able to run and then when i went to create the .exe again it was able to get passed that file but it was tripped up with the same error on a new file excel set cell color and border which I don't know how to make runnable.  The program I created works how i want in all circumstances I have which tells me the  programs that are stopping the build are unimportant to what I need but are imbedded in the RGT.  Is there simpler/smarter/different way for me accomplish my output to my file in excel so i can just avoid this problem? possibly using Activex? or possibly a way to remove these files from the RGT just in this application?


sorry this is so long



New file causing error

0 Kudos
Message 3 of 8
Accepted by RossGE

Hi RossGE,


First, what smercurio_fc was trying to say at first is that the VIs you've posted are purchased with the Report Generation Toolkit and shouldn't be posted.  In the future, please just post the name of the VI if you haven't created it.


Second, looking through your VI, I notice that there's a case structure at the beginning with a true constant wired to it.  Since this case structure only has one option can you remove that and try building your application again.


If that doesn't work, go to the Build Specification for the executable and change the following settings:


  • In the Additional Exclusions category, make sure that "Disconnect type definitions" and "Remove unused members of project libraries" are not checked.
  • Lastly, in the Advanced category, make sure that "Enable debugging" is checked.
The last one should be tried after all others, since it will increase the size of your executable.


Jared S.
Applications Engineering
National Instruments
Message 4 of 8


@jareds wrote:

Hi RossGE,


First, what smercurio_fc was trying to say at first is that the VIs you've posted are purchased with the Report Generation Toolkit and shouldn't be posted. 


Thanks for catching my too many negatives in my statement. Two nots still don't make a right in this case. Smiley Wink


0 Kudos
Message 5 of 8



First sorry i didn't even think about it I should of realized you would have them but i thought maybe something was wrong with my Report Generation Toolkit.  It won't happen again.


Second thanks for the help enabling the debugging solved my problem but yes it did make the executable much bigger I appreciate all your help



0 Kudos
Message 6 of 8

Hi RossGE,


Don't worry about it.  It's really not a big deal since it's just two VIs.  I just wanted to make you aware for any future posts that it's not always best to post VIs that you haven't written.


I'm glad to hear that make it debuggable fixed the errors that you were seeing.  Thanks for posting an update!

Jared S.
Applications Engineering
National Instruments
0 Kudos
Message 7 of 8

Thanks! I had the same problem. Changing the Build Specification settings worked perfectly

0 Kudos
Message 8 of 8