Showing results for 
Search instead for 
Did you mean: 

conflict resolution Labview myRIO-2016

Go to solution

I am using a project (see zip file) wrote using LabVIEW myRIO-2015 for the IMU sensor MPU9250. The computer that I am using has LabVIEW myRIO-2016 installed. It also has FPGA, Real time modules and drivers.

When I run the FPGA program (FPGA_MPU_rev1), it compiles properly and works fine.. But when I run the real time program (RT_MPU9250_main_rev1), I am asked to save the changes (figure1). After I choose save, the program runs fine for 128 iterations and then I loose the connection to the myRIO target (figure2). I choose Ok and run the program again. I get the conflict resolution error (figure 3 and 4). After I choose Apply, the program runs for 128 iteration and looses the connection again.


I used a different myRIO to check if its the hardware issue. But I still have the above mentioned errors. I even tried repairing the RT module using NI-MAX, but it did not help.

The program seems to work with a different laptop which uses LabVIEW myRIO-2015 software.
Can anyone explain what is wrong here?

0 Kudos
Message 1 of 7

Have you tried reformatting your myRIO? This might help clean up any connection issues or corruption that might be happening while running your code.


Have you seen this issue with any other applications you run on your myRIO? Has this specific application run smoothly in the past without this happening?

0 Kudos
Message 2 of 7
Accepted by topic author kumarasova

Try putting the Open FPGA VI Reference outside of your while loop in your RT code.

Matt J | National Instruments | CLA
Message 3 of 7

@ , Thanks a ton man. The program works fine,  after I put the Open FPGA VI outside the while loop.

But what would be the reason that the program works with LabVIEW myRIO 2015, even with Open FPGA VI inside the while loop


also @Sekine108, I already reformatted the myRIO, it did not help

0 Kudos
Message 4 of 7

@kumarasova wrote:

But what would be the reason that the program works with LabVIEW myRIO 2015, even with Open FPGA VI inside the while loop


I'm not sure about that to be honest. Always failing after 128 iterations made me think that there was some handle not being disposed which is why I suggested moving the Open FPGA VI Reference out of the loop.

Matt J | National Instruments | CLA
0 Kudos
Message 5 of 7

Hie y'all, thank you for all the tips and advices. But I got a question: it's pretty frustrating cuz we tried all these. And the formatting.


0 Kudos
Message 6 of 7

Hello, I'm trying to use your program to my MPU 9250, what was your wires? 

0 Kudos
Message 7 of 7