LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

When I maximize my FP at that time my gauge Control is not in shap..any idea..???

Solved!
Go to solution

Hello

 

When I maximize my FP at that time my gauge Control is not in shap..any idea..???

0 Kudos
Message 1 of 15
(1,962 Views)

Hi

 

could you post your vi?

 

may be we can look into your vi and try out a bit.

Regards
Freelance_LV
TestAutomation Consultant
0 Kudos
Message 2 of 15
(1,941 Views)

It seems the you have grouped everything and I also see the other indicators are also mishaped from the original. This happens when you group controls and when you select the scale object with pane for any one of the control/indicator so when you maximize/resize the shape changes.

-----

The best solution is the one you find it by yourself
0 Kudos
Message 3 of 15
(1,937 Views)

Here is my VI..

 

 

Looking forward to your valuable reply

 

Kumar

 

0 Kudos
Message 4 of 15
(1,909 Views)

Hi Thejaskumar,

                         How can we open your main VI without loading all your sub VIs?You better follow  P Anand's advice because not only the guages but also other indicators are also reshaped.

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Thanks as kudos only:)
Message 5 of 15
(1,899 Views)

Hi,

 

I turned off the VI property "maintain proportions" and this stops the re-sizing of the controls on the front panel.

-------
Mark Ramsdale
-------
0 Kudos
Message 6 of 15
(1,892 Views)

Hello

 

I tried your suggestion, but its still the same problem.....

0 Kudos
Message 7 of 15
(1,884 Views)

 

The VI Run Time position is set to maximize when run. And the 'Scale all bjects when window resizes' is selected.

un check this selection and save the VI. Run the vi.

Regards
Freelance_LV
TestAutomation Consultant
0 Kudos
Message 8 of 15
(1,878 Views)

Right click on the vertical scrollbar of your front panel. Goto Pane Sizing, and make sure that "Scale Objects while resizing" is unchecked.

-FraggerFox!
Certified LabVIEW Architect, Certified TestStand Developer
"What you think today is what you live tomorrow"
0 Kudos
Message 9 of 15
(1,867 Views)

I noticed that when the 'Scale all objects" is unchecked in the VI properties, the Panel Sizing settings on the right click menu are modified accordingly.

 

And it works the other way round too..

 

So either change in the VI properties, or change the right click menu item selection.

 

Edit: Oh! this holds good for the setting 'Right click on vertical scroll bar -> Panel Sizing -> Scale objects with pane' (not scale objects while resizing)

 

Regards
Freelance_LV
TestAutomation Consultant
0 Kudos
Message 10 of 15
(1,851 Views)