Showing results for 
Search instead for 
Did you mean: 

Using Labview with kinesis to control Thorlabs BPC303

Go to solution



Im afriad this has been asked before without an answer (Previous post), but here's hoping someone can help. I have attached a very simple VI I made to try and control a thorlabs BPC303. Using Thorlabs software I can control it fine with the same GUI, however when inserted into labview, it says "No suitable devices found". The serial number is correct (it is printed on the device) so I cant work out why labview cannot connect. I have checked that the thorlabs software has closed its connection with the device and tried restarting it to no avail.


Thanks in advance,



0 Kudos
Message 1 of 20

Hello md12g12,


Actually your case looks quite complicated. I tried opening your attached vi but without having the driver files (it searches for a Thorlabs.MotionControl.Controls.dll file) the Block Diagram looks quite empty:



The screenshots in your older thread look like they should be working - from Labview's point of view. No idea about the .NET driver from Thorlabs though. Do you have any public documentation on it that you could share here?


(Side-note: You could wire the error terminals in your VIs; in case there is any error raising up it makes it easier for you to debug.)

Ingo – LabVIEW 2013, 2014, 2015, 2016, 2017, 2018, NXG 2.0, 2.1, 3.0
0 Kudos
Message 2 of 20

I just found this guide from Thorlabs on the internet: The code you posted looks similar to the example in there - so it should be fine in terms of their .NET interface. Maybe check that it is exactly the same. If it does not work it is probably something you should ask Thorlabs. However you might have luck finding someone on this board who has the same hardware as you!

Ingo – LabVIEW 2013, 2014, 2015, 2016, 2017, 2018, NXG 2.0, 2.1, 3.0
0 Kudos
Message 3 of 20

Thanks, that was the guide I was using. And I suspect the issue is somewhere else now, other VISA devices are unresponsive. (Tried reinstalling NI VISA but am unable to find the devices at all)


Anyway thanks for your help!

0 Kudos
Message 4 of 20

Uuuuh, that sounds like there is a couple of dozen possible causes for your issue /-:

Ingo – LabVIEW 2013, 2014, 2015, 2016, 2017, 2018, NXG 2.0, 2.1, 3.0
0 Kudos
Message 5 of 20
Accepted by topic author md12g12

I have got it working with labview. To communicate with the BPC303 a few more steps were needed (see picture below). Also the serial number needs to be 7XXXXXX (also found on the machine) and then call the channels separately, rather than use a different s/n for each.


This post can be closed now.

0 Kudos
Message 6 of 20

Awesome work you did there! I am glad you found a solution, thank you for sharing it here!

Ingo – LabVIEW 2013, 2014, 2015, 2016, 2017, 2018, NXG 2.0, 2.1, 3.0
0 Kudos
Message 7 of 20



I'm trying to do something similar but with a Tholabs K-Cube inertial Motor Controller. I've been looking in your help documents but I can't make it works and I don't know what else try. 


I've a problem because it says that there is not suitable device found. However, I've done all the steps that you suggest in all the post that I've read ( It still doesn't working. 


I attach the VI and the errors and maybe you could help me. 


Thanks in advance!

Download All
0 Kudos
Message 8 of 20

Find Thorlabs devices.png

You can use this to scan your system to have it tell you what Kinesis devices it thinks it has attached to it.  If it finds none, or different serial number(s), or the type doesn't match what you think it is, that's your problem.


FYI that first node is from Thorlabs.MotionControl.FTD2xx_Net.dll and is a static method, so you don't need a constructor.

Message 9 of 20

Hello Kyle,


Thanks for your fast answer. I've been trying to use this SCAN but I'm not able to call the FTDI method. I don't know why. Do you have there the VI please? I want to know if it's my problem. 


Thanks again


0 Kudos
Message 10 of 20