Showing results for 
Search instead for 
Did you mean: 


Hi, all
  I posted this question in hardware section. but I think the software section should be the right place to ask. plus I haven't got replys.

we have a photometer, which is connected to PC by USB.  however, when you do remotecontrol, it actaully opens a vitural COM port, for example COM4. then you could send ASCII (text) command in HyperTerminal. To do this, you have to install some drivers coming with the instrument ,at first. however, now we want to control this meter by Labview . I tried to send the same ASCII command from "VLSI write" through COM port 4( I do close the HyperTerminal when I use Labivew). but there is no response.  I don't know what I am missing.  I guess if I may need to write a driver inside Labview to tell Labview which port he should be looking at. Oor is there some special opertation  for this kind of instruemnts?  I have been reading here , and I think this could be a hard problem.

the weird thing is that once you tried to communicate with the instrument by Labview, you won't be able to communicte with  it by HyperTerminal any more, even after you closed Labview. seems the COM port is freezed.

0 Kudos
Message 1 of 6

Seems that your device use an internal USB-RS232 converter.

If you use VISA-Close after using the COM port, your port should be free again for other resources. What version of VISA are you using?

Next thing is the USB driver of your device. I assume it uses the standard driver of the chip manufacturer. Maybe there is an update too.

However, if you succeed in Hyperterminal (so your serial settings baudrate,data/stop-bits, parity... protocol is right) but not with Labview, the most common pitfalls I come along are:

1. Termination character after sending the command. (In Hyperterminal you hit Enter, sa you need to add a carriage-return to your string. Have a look in the documentation of your device, what termination it use.

2. The VISA-Read has also the capability to use a termination character, so if you haven't disabled it, you are not always reading all data from the buffer.


Greetings from Germany

LV since v3.1

“ground” is a convenient fantasy

'˙˙˙˙uıɐƃɐ lɐıp puɐ °06 ǝuoɥd ɹnoʎ uɹnʇ ǝsɐǝld 'ʎɹɐuıƃɐɯı sı pǝlɐıp ǝʌɐɥ noʎ ɹǝqɯnu ǝɥʇ'

Message 2 of 6

I agree with Henrik,

I doubt that you need additional drivers for Labview.  If you can get it working using HyperTerminal, then it should also work using Labview as long as the ports are configured the same.  And as Henrik mentionned, the most common mistake is forgetting the end of line or return character (\n or \r\n). 



Message 3 of 6

I, too, have connected my device (in this case, a MKS Instruments 647C) using a virtual serial port. I'm running my RS232 cable from the device to a Serial-to-USB converter, which runs a USB cable to the computer. The virtual serial port is COM3. I want to use Labview to control the device, but I'm not sure where to begin. So I decided to test the hardware using Hyperterminal. The NI website has directions on how to test serial hardware using Hyperterminal.

I followed the procedure to the letter, but I don't get an "echo" back of the letters I typed in. I've made sure that the baudrate, parity bit, stop bit, etc. all match. I'm not sure what the problem is. The only thing I can think would be a problem is the fact that I'm using the RS232 device through a USB connection not a true serial connection.

One more thing I feel I should mention (but probably isn't a problem) is that there's no "direct to COMx" option in the Hyperterminal options (as specified in step #5 in the directions above), when I'm setting up the connection. However, there is a "COMx" option. Is that different from the "direct to" option? How did run your device using Hyperterminal?

0 Kudos
Message 4 of 6

Don't worry about the 'Direct to Comx'. If Hyperterminal is showing your new com port, then that's all right.

When do this test, do you have a loopback on the serial port and is it wired correctly? You need to jumper pin 2 to 3 if you have a db9 connector.

Message 5 of 6
Ahh...silly me. I did that and it works. Thanks!
0 Kudos
Message 6 of 6