Showing results for 
Search instead for 
Did you mean: 

Resource not found error in executable on development machine

I have a program I inherited that uses an NI-5660 digitizer. The program runs just fine in the development environment (2010 SP1). I am able to build the program into an executable, but when I open the executable, I get a series of errors. The errors are all of the format:



LabVIEW: Resource not found.


An error occurred loading VI ''.

LabVIEW load error code 3: Could not load front panel.



where xxxxxxxx is the name of a VI. The VIs that cannot be found are:

niTuner Ready

niTuner Send Software Trigger

niTuner Get Temperature with Refresh Interval

niTuner Get Cal (single)

niTuner Set Freq(f)

niTuner Set Attenuation

niTuner Initiate Scan

niTuner Get Cal (multi)

niTuner Set Freq(f array)

niTuner Config Scan Advance

niTuner Close

niTuner Get Attenuation

niTuner Initialize


Once the program front panel loads, if I click on the broken arrow, I see the following message pop up.


error screenshot


I'msuspect the problem is that LV can't find the niTuner DLL (nipxi5600u.dll), even though I tried explicitly including it in the build. I just reinstalled NI-RFSA 2.5.0, which automatically installs the niTuner drivers. And like I said, it works in the development environment. It does not work in executable form ON THE DEVELOPMENT MACHINE. Any ideas? Anything important I forgot to share?

0 Kudos
Message 1 of 24

Hi Nblume,


Im an Applications Engineer at NI UK and will help you with this issue. If the vi is running fine in the development environment the the issue will be with the way in which you created the executable file.


The error code: 'LabVIEW load error code 3: Could not load front panel.' refers to the front panel not being included as part of the .exe file when you created it. Does the vi open the front panel of any sub VIs when it is run on the development environment. If it does the the following KnowledgeBase article will help you ensure the front panel of any subVIs are included in the executable file.


Resource not found error in executable on development machine

Please provide me with the above information and try the above solution if appropriate. Let me know how this goes so I can assist you further.





Aaron. E
Product Performance Engineer
0 Kudos
Message 2 of 24

No, it does not open any front panels. Your link just linked back to my post, but I know which KB article you were trying to point me to because I had read it already. I tried changing the source file settings for the one VI that uses the 5660 so that the front panel is not removed, but I still got the exact same series of errors. In fact, the default setting was already to include the front panel for all VIs.


I think the front panel error may just be a symptom of the real problem, which is that LV can't load the niTuner drivers for some reason. I think the "resource not found" error is the real problem. Then again, I don't work for NI, which is why I am seeking help.

0 Kudos
Message 3 of 24

Actually, that link goes to a server that no one outside of NI has access to.  (Aaron, we can't see the domain.)


The correct link is

0 Kudos
Message 4 of 24

OK thanks for the further information. I am going to look further into this for you. I agree that the front panel error is likely to be just a symptom.


So that I can take this further could you produce a MAX technical report. If you are unfamiliar with this please refer to the following KnowledgeBase:


It would be great also if you could supply me with the code you are trying to run along with the executable.  If you would prefer not to post this information on the forums send me a private message and we can sort that out.


In the mean time I will continue to look into this issue for you.



Aaron. E
Product Performance Engineer
0 Kudos
Message 5 of 24

Thanks Ravens,


I was meaning to supply that link.

Aaron. E
Product Performance Engineer
0 Kudos
Message 6 of 24

TK Installer bug.


See here for the bug discription

and Here for the workaround



"Should be" isn't "Is" -Jay
0 Kudos
Message 7 of 24

Unless this behavior has been verified with other toolkits (Spectral Measurements and Modulation toolkits would be the only ones that apply to me), I don't see the relevance. I do not have or need the GPS toolkit. Nor do I have multiple versions of LV installed. The only version ever installed on this machine is 2010. So this seems unrelated to my problem, unless I am missing something.

0 Kudos
Message 8 of 24

Does the code use any subVIs within it? If it does what tasks are the subVIs doing.


I think the issue relates to the way in which the subVIs are being called in and how this relates to the NI-tuner drivers. Changing the way which the subVI is called in from memory may be a way to overcome this issue.





Aaron. E
Product Performance Engineer
0 Kudos
Message 9 of 24

There are plenty of subVIs, but I'm not sure what you mean by "the way in which the subVIs are being called in." I believe all of the subVIs related to the NI-5660 are contained in a single subVI. This subVI is called in many places throughout the program, but never simultaneously. The subVI is not reentrant. What else can I tell you to help?

0 Kudos
Message 10 of 24