Showing results for 
Search instead for 
Did you mean: 

QD Shortcut - Chage To/From Array

Hi Darren,


unfortunately I was able to reproduce this behavior in each and every newly created VI in LV2013 x64 I created since I found out about it. My first guess actually was a corrupted control, so I tried it with another scalar control next to the "offending" one, which, I seem to remember, changed to an array as I expected. After that I tried to figure out what was causing the trouble resulting in the screenshots I posted. In time I decided to try and restart LabVIEW in the hope something got messed up, and yes, there came a window about some DWARN messages after exiting LabVIEW, which I, if truth be told, receive from time to time - I stopped worrying about those.

But after I restarted LabVIEW, NO control whatsoever did me the favour of turning into an array ever since. Not even when I replaced the possibly messed up copies in my LV2013 x64-QD-folder with the original one from this very thread.


Again, I repeat - I had been working with this great shortcut since its release, on this very same computer (and on others). It is highly unlikely that I would have never, in all this time, used it for turning a control into an array in x64 before some days ago, when I became aware of this oddity.


This being said, I really think it must be something about my LV installation that's causing it and most likely nothing about the programming of the shortcut or indeed LabVIEW itself.

0 Kudos
Message 21 of 24

If it really is a problem with the installation, I think you should repair your install. Sure it will take a while, but who knows what other problems may crop up later if there is a core file that is corrupted or otherwise problematic?

0 Kudos
Message 22 of 24

You have point there. So I'll go down Sheldon's lane:

0 Kudos
Message 23 of 24

Thanks for this! I'm just now getting into QD, and I'm sure this shortcut will be used quite often!

0 Kudos
Message 24 of 24