LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Open a specific browser on labView

Solved!
Go to solution

The OS is windows 7 and the picture attached is the page of the Chrome configuration: URL= chrome://settings/defaultBrowser.

 

0 Kudos
Message 11 of 20
(3,697 Views)

If you drag an url to the desktop as a shortcut, does it have the chrome icon?

0 Kudos
Message 12 of 20
(3,696 Views)

Yes, here the example of the topic we are talking: 

 

Captura.JPG

0 Kudos
Message 13 of 20
(3,692 Views)

Sorry, I am out of ideas. If you open IE, does it complain that it's not the default browser? Maybe there is something corrupted in the registry or it has to do with the os language.

0 Kudos
Message 14 of 20
(3,687 Views)

Yes, Internet explorer ask me to become the defalut browser, so it indicates that isn't it. I can assure you that the first thing that I tried was it. It is no easy...

0 Kudos
Message 15 of 20
(3,681 Views)

No that it will help much but in the same llb

 

C:\Program Files\National Instruments\LabVIEW 2017\vi.lib\Platform\browser.llb

 

where the function Christian linked was found there is another VI called

 

Get System Web Browser.vi

 

If I run that on my machine it returns;

 

"C:\Program Files\Google\Chrome\Application\chrome.exe" --

 

Wire that to sysexec and it opens Chrome.

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 16 of 20
(3,675 Views)

 

I am going to check this library 

Thanks a lot.

0 Kudos
Message 17 of 20
(3,672 Views)

Hi, 

I found a vi that opens the defautt browser on that librar called "open URL in default browser(string)"!!

Thanks a lot. Im going to try

0 Kudos
Message 18 of 20
(3,669 Views)
Solution
Accepted by topic author aitorplaza

@aitorplaza wrote:

Hi, 

I found a vi that opens the defautt browser on that librar called "open URL in default browser(string)"!!

Thanks a lot. Im going to try


I mentioned that in the first answer above and I thought you were testing with that one.

 

There is no need to dig through "libraries" and pick a specific polymorphic instance.

 

That VI is in the palettes! (Dialog&user interface...help")

 

OpenURL.png

Message 19 of 20
(3,663 Views)

Hello guys,

 

Sorry for open the topic again but i have a similar problem.

In fact, i need use "activeX browser control" in my labview app. The problem is that the "activeX browser control" always open IE. 

Obviously i configured the default browser like chrome because the web page i wanted connected worked very well with chrome and did not work well with IE.

The device (pyrometer) gives me the ability of connect using the chrome browser. 

In advance thanks very much.

 

Martin

0 Kudos
Message 20 of 20
(3,532 Views)