Showing results for 
Search instead for 
Did you mean: 

OPC, create bound varaibles, why won't my OPC server show up anymore

I had it working before.  I could create a new I/O server which I linked to my OPC server.  Then I right clicked on the client I/O server and clicked on "create bound variables" where a tree structure came up in which I then selected tags to be bounded to my shared variables.  Now for some reason, I can't see it anymore.  I have tried EVERYTHING from restarting the OPC server to rebooting to configuring DCOM using that long kepware manual.  This is not the only PC that is doing it (LV2010).  I have another PC (both XP) with LV2009 that I have never got to work.  I am very frustrated and need some help.




0 Kudos
Message 1 of 12

Hi Matt,


When you say that you can't see it anymore, what exactly can't you see?  The tags that you want to bind or the OPC server?  Could you also provide a little more information about your setup?  What devices are you trying to get information off of?  If you can post a picture of what you are seeing, that may be helpful as well.


Hopefully we will be able to get this working for you soon.




Elizabeth K. 

National Instruments | Applications Engineer | 

0 Kudos
Message 2 of 12

Here are two screen shots.  One is on another computer of a co-worker.  It seems to work fine on his as it did on mine a couple of days ago.  We are both reading from the same OPC Server software which is remote over the internet.  It worked for me for a week and then stopped working all of a sudden.  I tried to enable all of the permissions for DCOM because this is the only information I found on correcting the problem.  I am fresh out of ideas.  I will wait for your reply before I go ahead and re-install Labview 2010 to see if this will work.  (Note: I tried re-installing the OPC Server software with no success).


Thanks for you help


Download All
0 Kudos
Message 3 of 12

Please Help

0 Kudos
Message 4 of 12

Are you using NI OPC Server or KEPServerEX?

What is the version that you are using of the server?

Is the server running as a service or interactively?

Fred Loveless
Kepware Technologies
0 Kudos
Message 5 of 12

I am using AO-OPC - OPC Server Software Version 2.0 by ABB.  The version  is 2.0. I am running it as a service

0 Kudos
Message 6 of 12

If you are able to run the server interactively I would try that and see if you can see it. This way both applications will be running under the same user. If that works then you will need to look into your DCOM settings to make sure that all accounts have been added to access and launch permissions. Keep in mind that the Kepware DCOM document is primarily for Kepware products and other vendors may have different requirements.

Fred Loveless
Kepware Technologies
0 Kudos
Message 7 of 12

I have used this:

to open up all of the DCOM settings.


I just figured out that I can access it.  I can't access it directly from my PC nor my laptop.  But, I can access it through my PC (database) with my laptop (toshlap).  This is impractical and won't work in my application.



0 Kudos
Message 8 of 12

The next thing to do is to check and see if you are getting any errors in the application or system event logs for the PCs when you attempt to connect and browse. Also have you installed any OPC Client or server applications on the PC since it was working properly? You could have mismatched OPC Core components. In some Operating Systems RPCss.dll can become corrupted which can manifest itself like this. If that is what is happening then this link can point you in the right direct to fix it.


Its a stab in the dark at best but you never know.

Fred Loveless
Kepware Technologies
0 Kudos
Message 9 of 12

I tried running the hot fix without success.  Any more ideas?

0 Kudos
Message 10 of 12