LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI TC01 works only through Remote desktop.

Solved!
Go to solution

Hello, 

 

I am experiencing a very weird problem and I wonder if anyone has encountered such an issue or has any idea how we can solve this problem.
 
I am using a NI TC01 temperature probe to read air temperature and do further evaluation. The problem is that NI temperature probe TC01 works only when I am accessing the PC (where NI TC0 is connected) remotely. If another person logs into the PC, in person and tries to run the test sequence we get the following error and the sequence terminates with an error.
 
"Error Code: -200022 Original Error Source: DAQmx Start Task.vi:7220002 Channel Name: Temperature Task Name: _unnamedTask<2> TestStand Step Name: Max_Temperature_Dev_469911"
 
When the operator does a self-test or opens test panels for NI Probe through NIMAX, then we get the following error (screenshots below). NI Max says that the ai0 resource is reserved by a different task. If I log in remotely to the PC, then I can open the test panel and read the temperature using NI-TC01. At a different instance, I had NI Max open while accessing the tester remotely, the NI probe worked okay and as soon as the operator logged in to the PC, the NI Probe gave the same error as shown below.
 
RavRav_0-1643654042962.png

 

We tried to reset NI configuration data (NIMAX> Tools> Reset Configuration Data), followed by PC restart and, that didn't help either. Any idea or suggestion on what can we do here?

 

Also, both operator and I log in to the PC with the same username. 

 

Here's some other relevant information:

- LabView Version: NI LabView 2018 SP1 (18.1.0)

- NI DAQmx 18.5.0

- NIMAX 18.5.0

 

Thanks for your time and feedback.
Ravi K

0 Kudos
Message 1 of 7
(1,428 Views)
It sounds like you're not closing the DAQmx task correctly when done with it. Maybe the local user is aborting the program or doing something unexpected?
I think the fact that it's working for you over Remote Desktop is just a red herring.
0 Kudos
Message 2 of 7
(1,368 Views)

Hi Gregory,

 

Thanks for responding. Perhaps I mixed two things and didn't explain the issue in detail.

 

If for the time being, we forget about the test sequence/LabView code (hence the DAQmx Task), the issue is visible directly from the Test panel using NIMAX. If I open the test panel or try to do a self-test on the NI-TC01 it fails while I am logged into the PC directly. If I click on the test panel, I get a pop with an error message: -200022, Resource requested by this task has already been reserved by a different task. But next moment, if I log into the PC remotely, and perform the self-test, the test passes, and I am able to open the test panel and take a temperature reading. To validate the issue, I closed the remote desktop and logged into the PC directly again and to my surprise, the same error message popped through the self-test and test panel in NIMAX.

 

What I don't understand is why the same steps/test using NI MAX works while the PC is accessed remotely and why things don't work while performing the same test on the PC directly.  

 

And BTW, I use the same user account/user name to log into the PC directly and remotely. So, it's not even a question of a different user. 

 

Thanks in advance if you have any other suggestions that I can try.

 

Ravi K

 

 

0 Kudos
Message 3 of 7
(1,353 Views)

I see, and just to make sure are you personally the one logging into the machine locally? Or do you call someone and they log in locally?

Have you tried logging in locally, rebooting the PC, and then opening MAX as the first thing?

0 Kudos
Message 4 of 7
(1,343 Views)

Hi Gregory,

 

I am in Toronto and the Tester PC is in Spain. I had someone else log into the machine directly and then have him log into the machine remotely using his laptop. The person was standing literally next to the Tester PC. While we were debugging I was on a video call with the person.

 

It's weird that the person can take temperature measurement (using NI MAX) when NI TC01 is accessed through a remote desktop connection but if that person logs into the Tester PC directly, then TC01 doesn't work. 

 

We tried rebooting and opening the NIMAX the first thing, as you mentioned and this problem doesn't go away. The issue can be reproduced on demand, locally. However, If I access the Tester PC remotely (being in Toronto), there's literally no issue. NI TC01 probe works fine.  

 

 

0 Kudos
Message 5 of 7
(1,338 Views)

Hi Ravi, thank you for confirming, this is a very strange problem.

0 Kudos
Message 6 of 7
(1,323 Views)
Solution
Accepted by topic author RavRav

Issue resolved.

We had a device connected to our Tester PC that provides access to the USB devices via ethernet. We stopped using the devices but the driver was still installed on the PC. So I uninstalled the driver and the TC01 probe is working with local login, without any issue. 

0 Kudos
Message 7 of 7
(1,275 Views)