From 08:00 PM CDT Friday, August 12 - 01:00 PM CDT Saturday, August 13, will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.


Showing results for 
Search instead for 
Did you mean: 

Multicolumn Listbox Keyboard Navigation Bug

Go to solution

Attached is a vi demonstrating a bug I observed in January 2008 with LabVIEW 8.5.  Now in LabVIEW 10 I see that this issue still exists.


The problem is observed while setting the multicolumn listbox value programatically, in effect selecting a row programatically, and then trying to navigate to a different row in the listbox using the up/down arrow keys.  Navigation does not start from the currently selected row.  Instead it starts from the row that was selected prior to the programatic change to the multicolumn listbox value.

Message 1 of 11

Thank you for reporting this behavior. I have created a corrective action request #255312 for R&D to further investigate.

Stephanie A.
Americas Marketing Manager
National Instruments
0 Kudos
Message 2 of 11

I'm still getting the same behavior in 2014...Smiley Sad

Not my tempo... AGAIN!
0 Kudos
Message 3 of 11

Hey everyone,


This behavior was additionally tracked with CAR 448710 and is now fixed in LabVIEW 2015

Message 4 of 11

Are you sure this was fixed in 2015? I just opened the example in 2016 and I'm still experiencing the same problem.

Message 5 of 11

I am actually seeing the same thing in 2016. We will investigate this internally.



Applications Engineer

0 Kudos
Message 6 of 11

This is also the case in LV 2015.0.1


Any updates? The current search feature in my program acts weird because of that.

0 Kudos
Message 7 of 11
Accepted by Larry_Stanos

There is a KB that provides a workaround for the behavior you're seeing.


(How Can I Make Persistent Programmatic Changes to the Value of a Listbox Control?)

Message 8 of 11

That worked. Fantastic, thank you.

0 Kudos
Message 9 of 11

The solution link is broken - can you share the method that worked for you?



0 Kudos
Message 10 of 11