LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview 2012 DLL bug need solution

DLL initialization routine failed error for lvanlys.dll..........Should be located in resource folder

 

When you place a sinewave generator vi on a vi call library function node error: library not found or failed to load.

 

Have viewed LV bug list. Did not find this bug.

 

Can you provide a patch to fix problem. Have all updates and problem not solved

 

Regards

 

Michael Ryan

0 Kudos
Message 1 of 14
(6,229 Views)

@wetland wrote:

When you place a sinewave generator vi on a vi call library function node error: library not found or failed to load.


This is way too little information. What are you placing where, exactly ????

 

Can you show a simple VI that demonstrates the problem?

 

Is your LabVIEW 2012 32 or 64 bit?

0 Kudos
Message 2 of 14
(6,226 Views)

Thank you for your reply this is my first time l am using this forum.

 

I have labview 2012 32 bit. program so that l can use the machine learning toolkit at a latter date.

 

Just create a new vi. place a sine wave generate vi in the blank block diagram and you get a pop up for error loading of lvanlys.dll.

 

To remove the error you have to turn off the computer because you cannot remove the popup.

 

lvanlys.dll is correctly located in the folder resource.

 

I am using Windows 7 64 bit. You cannot start to write a program because of this error.

 

Because l am using just a standard vi that comes with labview and an error occurs l can state its a program bug because it does not happen with labview 8.6.1

 

Does ni read the forum to provide solutions to program bugs? Originally l thought l was emailing ni

 

Regards

 

Michael Ryan

0 Kudos
Message 3 of 14
(6,206 Views)

@wetland wrote:

Just create a new vi. place a sine wave generate vi in the blank block diagram and you get a pop up for error loading of lvanlys.dll.


I have the same LabVIEW and same OS, and don't have a problems.

 

I am not aware of any "sine wave generate vi". Is this from a toolkit?

 

LabVIEW has: Sine wave.vi, Sine pattern.vi, Sine Waveform.vi, Sine Wave ptbypt.vi, None of those generate errors. Where's yours??

 

This is not a bug, but possibly some corruption in your computer, or a failed installation. Have you tried repairing the LabVIEW installation?

0 Kudos
Message 4 of 14
(6,201 Views)

Hi

 

Go to Programming - Waveform - Analog Wfm - Generation - Sinewave generator vi

 

If it works for you then you are lucky. This is my first bug l have found

 

Regards

 

Michael Ryan

0 Kudos
Message 5 of 14
(6,187 Views)

I must not have your toolkit....

 

All I see is "Sine Waveform.vi", there is no "Sinewave generator vi" in sight anywhere (see image). Are you really sure about that name? In any case, nothing in that palette generates any errors for me.

 

You did not say if you tried to repair your installation. What is the exact make and model of your CPU?

 

When you installed LabVIEW, did you use the default installation locations or did you "personalize" for lack of a better word? Were there any problems during installation? Did you reboot after the installation? What other NI software is installed?

 

Have you tried other functions? There are plenty of function that use lvanlys.dll. Do all the other functions still work fine? (for example try "A x B.vi" form the Mathematics...linear algenbra palette).

 

Do other labVIEW program run fine?

 


wetland wrote:

If it works for you then you are lucky. This is my first bug l have found


This has nothing to do with luck, because in my case everything works exactly as intended. Luck only plays a role with bugs that only occur once in a while when trying to reproduce the problem, but in your case it seems 100% reproducible on your system.

 

I still seriously doubt it is a bug (and I probably have found hundreds of real LabVIEW bugs over the years :D). If it really were a bug, you could post a link in the monthly bug thread. Is is checked regularly bi NI.

To be a confirmed bug, it needs to be reproducible by others (and also by somebody at NI).

 

To help out, I have tried hard to reproduce your problem, but since your instructions are insufficient and ambiguous it is still not possible. You need to give much more detail!

 

Does LabVIEW create a crash report? Is there anything interesting in the Windows 7 event viewer?

 

Have you checked your computer for viruses and malware? What antivirus program are you using (maybe it triggers a false positive reaction on this file).

 

0 Kudos
Message 6 of 14
(6,184 Views)

Hi

 

Thank you for your response. You have done what l have done and have no errors

 

I just did a normal download. Yes l have check for viruses and malware. No problems there. I am really just starting to use LV 2012 for the first time this weekend

 

As stated before as soon as you place the vi on a block diagram l have a pop up window informing me of the error.

 

Labview does not provide a crash report

 

Yes l did reboot the installation when requested

 

I do not know how to repair an installation so l have not tried

 

What other functions use lvanlys.dll?  I tried the A X B vi and it generated exactly the same problem

 

No problems during installation

 

I have real time module and instrument simulator wizard

 

os Windows 7 64 bit service pack 1. Using LV 2012 32 bit program due to requirement to use machine learning toolkit

 

CPU AMD 8 core. Two hard drives. One with OS Windows 7 the other with Vista. The hardware separation creates a two in one computer system. No problems with Adobe/window or other products

 

Windows 7 event viewer what is that?

 

I had LV 8.6.1 on another computer with the same antivirus and malware programs that produced no problems.

 

Thank you for all your ideas

 

Regards

 

Michael Ryan

 

 

 

 

 

 

 

 

 

 

0 Kudos
Message 7 of 14
(6,173 Views)

Thanks for the extra details. We must conclude that there is a general problem with lvanlys.dll in your case. This is such an integral part of LabVIEW that it would have been caught way before release if anyone else would have had the same problem.

 

Some earlier LabVIEW versions had problems with AMD CPUs and CPUs with many cores (e.g. 16 cores, due to a bug in the Intel MKL library), but not in this way. And these problems have been fixed in LabVIEW 2012. Do you know the exact CPU model? (It should be listed in the system properties). Maybe it is a brand new chip and AMD introduced yet another brand new incompatibility. 😮

 

To repair an installation, you would go to the control panel...programs (or similar) and select the entry "National Instruments Software". Select LabVIEW from the list on the left, then press the "repair" button on the right. However, maybe there is something wrong with the download, so if you have a fast internet connection, maybe you should download it again instead. The newest patch release is 12.0f3. Is that what you currently have?

 

If you go to "C:\Program Files (x86)\National Instruments\LabVIEW 2012\resource" and look at the properties of lvanlys.dll (right-click), what is the exact size in bytes. What is the modification date? What does it say on the "details" tab?

 

To look at the Windows event viewer, you would go to the control panel...administrative tools and double-click the "event viewer" entry. Look for anything that got logged at the time of the crash.

 

Good luck!

0 Kudos
Message 8 of 14
(6,154 Views)

the lvanlys.dll will have trouble to load if the Intel MKL isn't (properly) installed. I think a repair or complete reinstall of LabVIEW is in order, as it seems the intallation got corrupted somehow. And it could well be that the download got corrupted somehow, so altenbacks advice to try to redownload it (possibly using a different client or the web downloader from NI) might be very sound.

Rolf Kalbermatter
My Blog
0 Kudos
Message 9 of 14
(6,132 Views)

Hi

 

Ivanlys.dll file version 12.0.0.3 date created 6/26/2012 file size 1,152 kB

 

Processor AMD FX 8120. This is my home computer l use for Labview training and testing code l had no time to process at work

 

Called NI Australia. I was told the fix maybe months of never due to the type of processor used.

 

At work l installed the program on an intel computer and the program had no bugs.

0 Kudos
Message 10 of 14
(6,092 Views)