From 04:00 PM CDT – 08:00 PM CDT (09:00 PM UTC – 01:00 AM UTC) Tuesday, April 16, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview 2011 FPGA Compile Error

Considering that the Norton tools complained about the compilion programs, I am concerned that they may have tried to clean/remove the mentioned programs. As much as it's an annoyance, can you attempt to reinstall LV + FPGA + the Xilinx tools after the Norton tools have been removed and see if the problem persists?

0 Kudos
Message 11 of 24
(1,752 Views)

I tried to repair compilation tools particularly Xillinx compilation tools.While do so the installer ask the path or DVD , G\Labview\Distributions\Xillinx 12.5,but i could not browse the mensioned file in DVD 1, 2,and driver. Where could i find the files?

 

K.C

CLAD

0 Kudos
Message 12 of 24
(1,737 Views)

I have not run into this issue myself, but apparently the Xilinx tools should be on the second DVD of the Platform installation set.

0 Kudos
Message 13 of 24
(1,723 Views)

The Xilinx 12 installer will be located under DVD 2 in this location, "[DVD Drive]\Distributions\Xilinx 12".

0 Kudos
Message 14 of 24
(1,715 Views)

-EDIT- already answered, thanks Terry

0 Kudos
Message 15 of 24
(1,714 Views)

Ya . I found it. Thanks a lot.

 

K.C

CLAD

0 Kudos
Message 16 of 24
(1,701 Views)

Hi Brad,

 

The WinXP issue was resolved by replaced the version of libBZ2.dll (located in C:\Windows\system32) with the version that came with Xilinx Tools.

 

TEMP/TMP were set to C:\Windows\Temp. This issue is due to a permissions issue arising from an installation of CYGWIN - my own fault. I should probably repair/reinstall Windows 7 at some stage.

0 Kudos
Message 17 of 24
(1,696 Views)

That would be the most absolute way to ensure that the problem gets fixed, but enough poking/prodding with tools such as depends.exe (to watch what the compile worker does during execution), procmon, or a similar program to try to see what is happening around the launch of the tools that are failing to run. 

 

Considering that Xilinx tools includes a lot of libs/tools that are also part of Cygwin, and version issues can arise fairly easily, I would not be surprised if it were some other library installed by Cygwin that the normal Windows DLL loading system is finding first and attempting to use that library that is incompatible with what Xilinx provides. I leave it to you to decide how painful a Windows reinstall will be in the face of trying to untangle the issue...

0 Kudos
Message 18 of 24
(1,693 Views)

Hi jnallen,

 

I am getting a similar error code on compiling my FPGA VI. I am using LabVIEW 2012 and FPGA 2012. I followed the same procedure that you mentioned above about copying the libBZ2.dll from the Xilinx tools folder into the Windows/system 32 folder. Yet, I get the same error after compiling. My system is running on Windows 7.

 

Thanks for your help in advance.

 

Chetan

 

 

0 Kudos
Message 19 of 24
(1,548 Views)

Just a similar error (e.g. a file is not being found) or essentially the same error (e.g. a .bld file is not being found)? Or is it even more different than that?

0 Kudos
Message 20 of 24
(1,529 Views)