Showing results for 
Search instead for 
Did you mean: 

Labview 2011 FPGA Compile Error



I'm new to FPGA. I want to use Labview 2011 SP1 with the Spartan 3E starter kit from Xilinx (Spartan 3E driver available from NI labview website).

I'm trying to work my way through the examples that came with the driver. I've run into the same compiler error with a number of the examples. The error is attached.


Error 7 occurred at Read from Text File in>>

Possible reason(s):

LabVIEW:  File not found. The file might have been moved or deleted, or the file path might be incorrectly formatted for the operating system. For example, use \ as path separators on Windows, : on Mac OS X, and / on Linux. Verify that the path is correct using the command prompt or file explorer.



I've checked the registry to ensure that the path to the compiler is correct.


Any assistance would be welcome.




0 Kudos
Message 1 of 24

Hi James,


I'd recommend performing a repair of the installation on the Spartan 3E Driver to replace any missing files that could possibly be missing from the installation directory on your machine. You can do this by re-running the Spartan 3E installer.


Please let me know how you get on!

Alex Thomas, University of Manchester School of EEE LabVIEW Ambassador (CLAD)

0 Kudos
Message 2 of 24

I uninstalled the Spartan 3e driver & the Labview FPGA module, including the Xilinx Tools (10.1 & 12.4). I re-installed these products and I'm getting the same error.


I've also got a version of Labview 2009 running on this machine - just in case this makes any difference.


Any other ideas?

0 Kudos
Message 3 of 24

This sounds like it's a FPGA compile worker issue, namely that either an expected file is not being produced by the Xilinx tools or the tool used to create the file is not being run. Can you attach your compilation log? Also, do you have Xilinx tools other than those provided by NI installed on the machine?

0 Kudos
Message 4 of 24



I don't have any Xilinx tools installed - other than the ones that installed with the Labview FPGA module.


I have attached the compilation logs and output results from my attempt.


I have renamed the extension on the following files from .lvtxt to .txt







Download All
0 Kudos
Message 5 of 24

More output files attached.

Download All
0 Kudos
Message 6 of 24

The XilinxLog is concerning in that it seemingly isn't running any tool after the PlanAhead resource estimation tool. If I were trying to debug this issue myself, my next step would be trying to run the tools and see if they complain about something or other, making sure to set your XILINX environment variable correctly.

0 Kudos
Message 7 of 24

Thanks for your suggestions. This issue is now resolved.


When I tried to execute the Xilinx tools application 'ise.exe' (located at C:\NIFPGA\programs\Xilinx12_4\ISE\bin\nt) , the same error appeared.

I'm using Windowes XP SP3 and the 'LIBBZ2.dll' file (located at C:\Windows\system32) has a 1999 date. This file is also part of the Xilinx tools install - located at C:\NIFPGA\programs\Xilinx12_4\common\lib\nt, with a 2011 date. I copied the version from the Xilinx tools install to 'C:\Windows\system32' and saved the older version as backup.Now the compilation works.


On a separate note, I also had a problem with an install on a Windows 7 laptop. Anytime I went to compile, it appeared to start and stopped shortly afterwards without doing anything. When I ran the 'ise.exe' file, it executed appropriately. It turned out that I was having a problem writing to the Windows temporary directory. I changed the directories to which the environment variavbles TEMP and TMP were pointing. This resolved that issue.

0 Kudos
Message 8 of 24

Did this also resolve the issue on the WinXP system? What was the TMP/TEMP variable set to and did you change it manually at some point?

0 Kudos
Message 9 of 24
Hi I have a similar problem. But I use NORTON internet security, which blocks the compiler and quarantine the compile worker exe. ( sonar protection) even if i disabled the sonar as well as the Norton Internet security. I uninstalled NORTON, after that the compile worker shows error and cannot find the files. Any suggestions please.
0 Kudos
Message 10 of 24