LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabView FPGA module: internal software error -61499

Hello !

I am new to FPGA programming, and I need some help on an error I get every time I try to compile a simple VI : While loop with just reading the value on input A0 and show it with an indicator.

Whenever I try the compliation process, I get the error -61499 (translated from french to english) :

 

Error -61499 occured at : niFpgaXml_GetValue_String.vi<-niFpgaBuild_CheckSignature.vi<-niFpgaBuild_DetermineRunButtonAction.vi<-niFpga_RunButton.vi:3

Possible reasons :

LabVIEW FPGA:  An internal software error occured in LabVIEW FPGA module. Please contact support at ni.com/support.

Additional Information: Missing required XML tag (/GenerateCode/JobState)

 

I tried changing names of files and devices to avoid spaces and other characters.

I also tried to find a temp dll called perl58.dll but I did not find it (I saw this on other posts).

My FPGA board is a PXIe-7962R with a digitizer adapter NI-5751.

 

Thanks for your support.

0 Kudos
Message 1 of 9
(4,285 Views)

Hello osramos,

 

I found in our internal search three similar Support Requests and a forum (here).

 

All of them have been solved by reinstalling the whole software including LabVIEW. The origin is unknown, maybe some corrupted files. But only three close SR indicates that it's really a rare issue. Moreover, the behavior has been noticed only for LabVIEW versions prior to 2011.

 

Regards,

Jérémy C.
NI France

0 Kudos
Message 2 of 9
(4,249 Views)

Hello !

Thanks for your answer.

I would have preferred not to reach a so extrem solution but I was thinking to do that anyway.

I will try and see if it solves the issue before tagging the post as solved.

 

Thanks again.

0 Kudos
Message 3 of 9
(4,232 Views)

This is an ancient thread, but I just ran into this problem with LabVIEW 2016. My PC froze during the build process and afterwards I got the same error message as the original poster.

 

Before trying to reinstall LabVIEW (which would take ages) I messed around the system a bit and found that only one FPGA build specification was problematic, others would run just fine. I thus concluded that the problem could be in the compilation cache. And sure enough after renaming the problematic build folder, the FPGA compiles again.

 

The cache is located here:

C:\NIFPGA\compilation\

----------
Although I've been 10+ years long fan of LabVIEW, I started to discourage engineers to start new projects in a SaaS language. NI must first regain trust within its community.
Message 4 of 9
(3,362 Views)

Hi,

I'm getting this now. 

Generated a new build specification within explorer and its compiling again.  Hope it works, having some issues recently with connecting to the target and seeing it in NI-Max.

 

Have a support ticket and they had me force reinstall some things and this popped up.

Thanks for posting and giving the idea.  Changing the folder name didn't work for me.

 

Jim

0 Kudos
Message 5 of 9
(3,329 Views)

Thanks Benjamin!

I ran into the exact same scenario as you, blue screen death during build, and after that I had the same error message. If I had stopped reading after NI's response above I would have had to reinstall my whole LabVIEW environment. So you saved my day!

Message 6 of 9
(3,218 Views)

Thanks for the help....I was able to get it to work by hitting Build in the Build Specification......Same issue, laptop froze during the previous compile

 

Also, my error was:

Error -61488 occurred at niFpgaXml_GetValue_String.vi<-niFpgaBuild_GetCodeGenSignature.vi<-niFpgaBuild_CheckSignature.vi<-niFpgaBuild_DetermineRunButtonAction.vi<-niFpga_RunButton.vi:6730002

0 Kudos
Message 7 of 9
(2,073 Views)

I ran into this mistakes too because of sudden power failure during FPGA compilation. My solution is to delete the folder located in C->NIFPGA->compilation->(folder), under which there should be a folder (or even more) that has the same name as your error FPGA vi. Then it works.

Hope this helpful.

0 Kudos
Message 8 of 9
(1,298 Views)

Deleting the corresponding catch file works for my case! error -61498

0 Kudos
Message 9 of 9
(556 Views)