LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW random crashing after reading ACCESS database

Solved!
Go to solution

Hello all,

 

I'm currently reading an ACCESS database (.mdb) and using database connectivity toolkit. At the moment

when I run the VI, randomly LabVIEW crashes. I have the error handler, but it doesn't give time to send error.

LabVIEW just closes up a dialog appears, mentioning that LabVIEW just crashed and if I wish to restart LabVIEW.

When I open up the VI again, the RECOVERY dialog menu appears.

 

I'm going to attach the VI, maybe my code is wrong. As I said this error comes up randomly. Sometimes it runs very

well.

 

Please some advice?!

 

Many thanks to all!,

 

José Luna.

 

 

Download All
0 Kudos
Message 1 of 9
(2,420 Views)

I don't see anything in the code that would cause a crash.  However when I run the code, it is ignoring the database calls in the TRUE case and using the data array from the FALSE case.  So maybe there is something about your dB that is causing the crash.  Do you have the file open in Access when trying to query from it inside Labview?  I don't expect that to cause a crash but I can't say for sure.  Do you have an outdated driver or maybe the wrong driver? 


aputman
LabVIEW 2017
LabVIEW Programming
Message 2 of 9
(2,388 Views)

Yes, I added the FALSE case to test if the scenario when I read the .mdb file (TRUE case) is causing the problem. Everything points to be indeed the connection with access database. But I'm not sure, that's why I'm asking here in the Forum.

0 Kudos
Message 3 of 9
(2,378 Views)

Did you try my suggestions? Are you able to successfully test the connection in the Data Link Properties dialog (double clicking the UDL file)?  

 


aputman
LabVIEW 2017
LabVIEW Programming
0 Kudos
Message 4 of 9
(2,375 Views)

Yes, that basically how I created the UDL. Last step is to test the connection and it tells me that connection is successful.

0 Kudos
Message 5 of 9
(2,369 Views)

Hi JLuna ,

 

These types of crashes are very conserning, and difficult to isolate.

Could you share the crash report generated?

 

Kudos are welcome 😉 marked solutions are awesome!
0 Kudos
Message 6 of 9
(2,325 Views)

Sure, here it is, one of many reports I have been sending:

 

Report ID: 22d2667d-dd0b-465a-823a-97717e316274

 

0 Kudos
Message 7 of 9
(2,316 Views)

When I created the UDL I have at hand two drivers that could normally be used to connect to an ACCESS Database.

 

1) Microsoft Jet 4.0 OLE DB Driver

2) Microsoft Office 12.0 Access Database Engine OLE DB Driver

 

Do you know any other driver available I can try? I'm currently using option 2)

 

Thanks in advance.

0 Kudos
Message 8 of 9
(2,315 Views)
Solution
Accepted by JLuna

I just tried the other driver Microsoft JET 4.0 OLE DB Driver and is working like a charm. I read this article https://www.connectionstrings.com/ace-oledb-12-0/info-and-download/ and which tells that, many people had

problems with Microsoft Office 12.0 Access Database Engine, using windows 64 bits or 64 bits Office 2010. In my case, in have windows 7 (64 bits). So I just created a new UDL with Microsoft JET 4.0 OLE DB Provider. Until now, LabVIEW has not crashed. If it happens (hope not) I will post it again.

 

Thanks all for you comments!

0 Kudos
Message 9 of 9
(2,307 Views)