LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

[LabVIEW 2017 + Arduino + LINX]Reading more than one analog channel

Solved!
Go to solution

Hello guys.

I'm trying to read some industrial sensors with 4-20mA standard.

I tried to read them separately and it works well, problems come out when I try to read them both in the same VI.

This is the VI that I attempted to use to to read them both:

(attachment)

 

I tried it and the sensor at pin 11 works, while the one at pin 10 doesn't, perhaps I didn't use the array properly?

(I tried to post this on the LINX forum, but it seems to be quite dead)

0 Kudos
Message 1 of 6
(2,915 Views)

I am not sure why you feel it necessary to convert an array to a cluster and then back to array!

Not saying that is what is causing you your problem, but it is completely unnecesary.

 

.

0 Kudos
Message 2 of 6
(2,804 Views)

Thanks for the reply, so how can I split the output of the analog channels?

0 Kudos
Message 3 of 6
(2,798 Views)

Index Array

 

I would recommend looking at the online LabVIEW tutorials
LabVIEW Introduction Course - Three Hours
LabVIEW Introduction Course - Six Hours

0 Kudos
Message 4 of 6
(2,795 Views)

But using Array Index will make me read one channel at once, won't it?

I meant if the loop is repeated 10 times and I've two indexes I'll read 5 times sensor 1 and 5 times sensor 2, also I need to implement an autoindexing

 

Anyway I'll try to study more the array part

0 Kudos
Message 5 of 6
(2,787 Views)
Solution
Accepted by phederigo

Never mind guys, after studied array a little bit more I understood how to use them properly, it's quite easy and doesn't need any loop (unlike I thought)

 

After debugging the circuit a little bit I got the idea to try with another analog pin and it worked; so basically the problem was that one Arduino's pin somehow stopped to work

0 Kudos
Message 6 of 6
(2,779 Views)