LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LIN Communication issue with YinLun Pump

Solved!
Go to solution

Hello, I am currently facing a LIN communication issue with a pump. The pump in question is a YinLun 180W EP150i pump. (I can provide you with the technical documentation if needed.) I am attempting to communicate in LIN using a very basic program that I had previously tested and it worked with another pump.

 

sasquatchd_0-1700034066008.png

Here is what the program looks like; it's just a program where we load the LDF of the pump and then add the data to be written (rotation speed setpoint). However, when I try to do this with the pump, it goes into fault mode (hibernation), which corresponds to maximum speed. This mode is activated when there is no LIN communication. Yet, I load the LDF properly and still execute my program.

 

 

0 Kudos
Message 1 of 5
(419 Views)
Solution
Accepted by topic author sasquatchd

I am using : 

-CDAQ-9189 Chassis 8 Slot,

-NI-9860,

-TRC-8546 Cable Transceiver

0 Kudos
Message 2 of 5
(417 Views)

What do you mean by fault mode?

Is the pump going into the fault mode? Or the LIN interface?

Can you add a XNET Read (State LIN Comm) VI for both sessions?

0 Kudos
Message 3 of 5
(364 Views)

Fault mode is like a security mode for the pump which is activated when there is no LIN communication.

What do you mean by adding a XNET Read ? 

what are the sessions ?

I am new at this topic so I dont really understand what u are talkin about

0 Kudos
Message 4 of 5
(346 Views)
Solution
Accepted by topic author sasquatchd

If you are not familiar with NI-XNET, I recommend you spend some time exploring Getting Started with NI-XNET LabVIEW API

 

To debug your issue, I suggest that you Log Bus Traffic with NI-XNET Bus Monitor While Running NI-XNET Application. Enabling Bus Error Frames in the Interface and Database Settings might be useful as well.

0 Kudos
Message 5 of 5
(334 Views)