cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Installing LabView 2016 on Ubuntu 16.04 LTS - NI Example Finder not working

Installing LabView 2016 on Ubuntu 16.04 LTS - NI Example Finder not working

I am attempting to install LabView2016 on a Ubuntu 16.04 LTS laptop.   Used the following command to install:

 

sudo sh ./INSTALL

 

When I try to call the NI Example Finder from the LabView Menu, nothing happens.   Then I call the program from the command line:

/usr/local/natinst/share/example finder/1.0/bin$ ./NIExampleFinder

I get a pop-up box with the following error:

An error occurred while trying to find your NI application software names and paths.

It looks like the Examples do exist on the machine under /usr/local/natinst/LabVIEW-2016-64/examples - so not sure if there is anything I can do to link these up?  When I dismiss the pop-up and try to access anything through the NI Example Finder, nothing is available.

When I ran the install, it produced the following errors:

 

error: open of niwebpipelinei-2.0.5-f3.i386.rpm failed: No such file or directory
./INSTALL: 406: [: Illegal number: 
expr: syntax error
niwebpipelinei-2.0.5-f3.i386.rpm 0 kB
expr: syntax error

Not sure if that package is needed or the install script needs to be updated.

 

The install then produces a multitude of the following errors:

 

/2016LV-LinuxPro/bin/cpio: cannot make directory `.': File exists
/2016LV-LinuxPro/bin/cpio: ./usr/local/natinst/share/example finder/1.0/products/labview/16.0/exbins/english/platform: Value too large for defined data type
/2016LV-LinuxPro/bin/cpio: cannot make directory `.': File exists
/2016LV-LinuxPro/bin/cpio: ./usr/local/natinst/share/example finder/1.0/bin: Value too large for defined data type

Not sure if these error are the problem or not.

 

Thanks in advance for any help in this matter.

0 Kudos
Message 1 of 3
(283 Views)

Re: Installing LabView 2016 on Ubuntu 16.04 LTS - NI Example Finder not working

Hi,

Ubuntu is a Debian derivative and uses (.deb) packages while (.rpm) is used on Red Hat (and other NI supported distributions).

You can try to convert one format to another, but I am not sure how well that would go.

 

Let me know!

0 Kudos
Message 2 of 3
(223 Views)

Re: Installing LabView 2016 on Ubuntu 16.04 LTS - NI Example Finder not working

Hi GrouchyMama

Thanks for the reply.  I believe their script takes care of this eventuality as it is using cpio to un-archive the rpms and installing them that way.   I could use alien and transform the rpms to debs, but I would need to go through their install script and change it appropriately.   Hoping for a simpler solution with a great possibility of success.   I was wondering if anyone who has installed on ubuntu has had similar results?

 

Thanks

0 Kudos
Message 3 of 3
(210 Views)