Showing results for 
Search instead for 
Did you mean: 

How to connect cRIO-9014 to USB port of PC?

I am using cRIO-9014 for my research, when I connect cRIO with network cable, it worked good with IP address : 192. 168. 1. 3.

Now I want to connect cRIO to USB port using TRULINK, in MAX cRIO was detected and showed running with the same IP as before.

But the question comes that in Add Targets and Devices, no items found below Real-Time CompactRIO. I do not know how to solve it.

Thank you.

0 Kudos
Message 1 of 7

What is "TRULINK"?  A google search brings up a lot of different possibilities.  Is it some kind of USB to Ethernet adapter?

0 Kudos
Message 2 of 7

Yes sir, connection like : cRIO 9014 -- network cable -- TRULINK -- USB port of computer.


0 Kudos
Message 3 of 7

Hi pem,


I'm not sure if the TRULINK is affecting matters or not so I think we should start by ruling out other possibilities. 


Have you followed the troubleshooting steps in this KB:


I know you said you were able to add it to the project when you were using the network cable, but I suggest making sure all the software etc. is set up the same way. Have you reinstalled any software since it worked? Also, is the ip address of the cRIO in the same subnet as your computer?

0 Kudos
Message 4 of 7

Hi Alisha,


Thank you for suggestion, everything keeps the same while I used USB port rather than network port behind the computer. Now if I connect cRIO-9014 with network port again, it works fine. I tried to ping the IP address of cRIO copied from MAX, 100% of packages lost, the help on website could not help me coz I can see cRIO in MAX.


By the way, the IP of cRIO is, when I plugged in ,it says:

ASIX AX88128 USB2.0 to Gigabit Ethernet adapter Ip:, subnet:

0 Kudos
Message 5 of 7

If 100% of packages are lost when you ping it, then the fact that it shows up in MAX could be irrelevant. It's evident that there are issues communicating with it and that's probably why you are unable to add it to your project.


What it comes down to is that this is not a recommended configuration for the cRIO. We would recommend that you plug the ethernet cable directly into the computer or network. 

0 Kudos
Message 6 of 7

pem wrote:

By the way, the IP of cRIO is, when I plugged in ,it says:

ASIX AX88128 USB2.0 to Gigabit Ethernet adapter Ip:, subnet:

Well, that's not going to work.  The IP address of the adapter needs to be in the same subnet as the IP address of the cRIO.  Change your adapter address to something in the 192.168.x.x subnet such as and see if that fixes the problem.

0 Kudos
Message 7 of 7