Showing results for 
Search instead for 
Did you mean: 

Help - Error 10401

Hi All, 


Let me open by saying I am an IT person trouble shooting this for someone else and I have almost no experience with the Labview software. The scientist using the software is only informing me that his program will not execute properly.


A little background; the program I am trying to run was developed approximately 10 years ago using Labview v5.1 and a NI PCI-6052E data card. The machine that ran the program is no longer working so I brought the program and card over onto a Windows 7pc with Labview 2012. (the older installation discs are not available to us)


I posted to the forum and had the program updated via the Version Conversion section so that it works with v2012 (or at least opens). The problem that I am getting when I run it is this error ‘Error – 10401 occurred at AI Group Config. The specified device is not a National Instruments product’.

Tech support suggested an older driver, which I installed, NI-DAQmx 9.6.1, and the error still persists.


The tech thinks that since the program was developed using T-DAQ that I need to update it somehow to recognize DAQmx functions.

Any help is very much appreciated. I am willing to share whatever I need to get this sorted out quickly. Please let me know if you need the program, screenshots, system specs, or any other information.


Thank you in advance for any assistance you can provide.



0 Kudos
Message 1 of 7

Try this link


The error maybe due to the fact that LabVIEW when first launched looks into all available and installed components and if you have installed components which you have run after running LabVIEW, this can happen.


The solution is given in the link if this is the problem.

0 Kudos
Message 2 of 7

Thank you! This got me through the hardware problem, I think.


When I launch my program, developed v5.1 running on v2012, the errors are gone but my data is still not graphing.


When I adjust the gain the peak signal responds appropriately on my Optiphase box, but still no graph.


Any ideas?

0 Kudos
Message 3 of 7

Are you sure you have thr right graph to display the data? 


I cannot think of any reasons why this would be happening. It is possible that the version change might have affected some sub vi's. Try re-wiring another graph.

0 Kudos
Message 4 of 7

I agree with the sub vi assessment. When I open the program it looks for the lvdaq.dll in a certain location, where v5.1 kept it, but finds it in a new location that corresponds to v2012 and this seems to be ok.


Do you have a sample graph you could send me? I only have the one program to troubleshoot. Or maybe point me in the direction of sample programs. As I mentioned earlier I am troubleshooting for the scientist and have extremely limited program knowledge.


Your help is highly appreciated.

0 Kudos
Message 5 of 7

I can't run it anyway as my version is different, just like you. Also, i wasn't sure which program to run as your file included a number of programs.


What kind of sample/example program do you want?



0 Kudos
Message 6 of 7

I wasnt sure if Labiew had any 'demo' programs.


I have reached out to the local university to see if they can lend a had.


Thank you!

0 Kudos
Message 7 of 7