LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -88716, the requested operation failed because the versions of a driver installed on the local and remote system are different...

Solved!
Go to solution

Dear all, 

 

I'm very new to LabView and I'm facing the error -88716, figure_1_error-88716. I know there are already similar questions from other people and I have tried to follow the suggested solutions, but  none of them seems to help. 

First, the "Add/Remove Software" window looks different for me then in the suggested solutions, I assume that that is because of NI MAX updates, figure_2_add-remove-software_window. Second, as I understand, all the software are up to date, as there are no software in the update section or with the "Bang icon". Figure remark: under "available" column only the visibly versions are available to be selected.  

 

I even deleted and reinstalled NI-DAQmx for the Remote Systems, hoping that it would resolve the problem, but still, I have the same problem. Then I moved on to downgrading the NI-DAQmx of My System  to 21.0, it did not help either. 

 

As suggested on NI-page, I also reset NI MAX Database, and as you can guess still not working. 

 

In figure_3_My_and_Remote_System_software, I have attached the software I have in My System and in the Remote Systems, hopefully someone can see what is wrong. 

 

Additional information, I'm using the NI MAX with CompactRIO-9056 and at the moment only IN-9210 module is connected. 

 

I appreciate all the hints and help!

Thank you in advance,

Hossein 

0 Kudos
Message 1 of 5
(171 Views)

Hi Hossein,

 

do you mind to show us your figures?

 

Which software is installed on your cRIO target?

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO
0 Kudos
Message 2 of 5
(164 Views)

Hey GerdW,

 

Thank you for your response. 

 

Sorry, for some reason the images didn't came through with the post, but here they are. 

 

Not sure if this is what you mean, the software package that I installed was "LabVIEW 2021 SP1 and Drivers", at least the following software should be installed, LabView, LabView RT, LabView FPGA, CompactRIO and Device Drivers. 

 

Kind regards,

Hossein

0 Kudos
Message 3 of 5
(155 Views)
Solution
Accepted by topic author HosseinBakhtiari

The problem was solved by downgrading the NI-DAQmx correctly. Below are the steps (thanks to NI support) in case anyone is facing the some problem. 

 

I would recommend downgrading the driver on your host computer from the 22.5 version. You can uninstall the driver using NI Package Manager: https://www.ni.com/hu-hu/support/documentation/supplemental/18/uninstall-national-instruments-softwa...

Then reinstall an older version (21.0) which you can download here: https://www.ni.com/hu-hu/support/downloads/drivers/download.ni-daqmx.html#409845

0 Kudos
Message 4 of 5
(69 Views)

Hi,

I am facing the same issue. I followed your steps by unInstalling the drivers and reinstall correct . But i am getting same -88716 error.Icompatible version. Is there any solution for it?

0 Kudos
Message 5 of 5
(34 Views)