LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 11 at TCP Wait On Listener (RT project)

Solved!
Go to solution

error 11.png

Well, don't know what else to say other than I have no idea where to go with this one, being that it is an undefined error. Error 11 on the TCP Wait On Listener. I didn't catch this error earlier because it is occurring a little later after it's been running for 10 minutes or more usually.

 

I attached my VI, the TCP logic is in the furthest upper right hand loop. LabVIEW 2020 and a cRIO 9053.

0 Kudos
Message 1 of 14
(744 Views)

This seems pretty weird because error 11 is usually "Too many files open".  I don't have 2020 installed to look at your VI to see if you're also doing any file operations in that area, but I'd check that and check to see if you're closing them after you're done with them.  

 

Networking error codes should be limited to what's in this list so I really don't have a better idea.

Message 2 of 14
(737 Views)

error 11.2.png

I had forgotten to connect these wires circled in red through this case statement in my main loop, I wonder if that was it. So far so good. But kinda weird if it fixes it though because this is not related to the TCP logic in any sort of way (that I'm aware of). 

0 Kudos
Message 3 of 14
(724 Views)

Nevermind, didn't fix it. Lol. 

0 Kudos
Message 4 of 14
(723 Views)

Here's a couple screenshots of my TCP loop if you're curious

 

tcp loop 1.png

 

tcp loop 2.png

0 Kudos
Message 5 of 14
(721 Views)

Hi,

 

I may be wrong but I think references are supposed to be kept live in a shift register, if you are going to re-use them from one cycle of a while loop to another.

0 Kudos
Message 6 of 14
(711 Views)

I think I have a new lead. It only seems to throw error 11 when my client is connected to it. Otherwise, the server just sits there and runs on the cRIO just fine.

 

Here's my client (VI also attached):

tcp client.png

0 Kudos
Message 7 of 14
(687 Views)

How about something like this?

 

Bonkerz_2-1628019512277.png

 

 

 

0 Kudos
Message 8 of 14
(678 Views)

@N_743 wrote:

How about something like this?

 

Bonkerz_2-1628019512277.png

 

 

 


I added the shift registers on the server side references (still getting the error), but I haven't tried on the client side. I'll try that now.

0 Kudos
Message 9 of 14
(667 Views)

Putting shift registers into the client tcp references gives me an error, Error 1. I'm pretty sure none of the examples/tutorials I've looked at used shift registers either, but I could be wrong. But I think it's because the connection ID is always changing

error 1.png

0 Kudos
Message 10 of 14
(665 Views)