LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

EXE no response

I converted a piece of code from LabVIEW 8.5 to 2012.  I compiled the code into an exe and tried to run it.  There is no errorr, but the front panel doesn't respond to my mouse clicks.  I tried clicking all the buttons and menu items, and no reponse. Right clicking doesn't get me a response either.  Any thoughts on that?

------------------------------------------------------------------

Kudos and Accepted as Solution are welcome!
0 Kudos
Message 1 of 5
(2,717 Views)

My first thought is that you have an Event Structure with code that is not being reached in an event that "Lock Front Panel Until Event Completes".  Can you share some code?


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
Message 2 of 5
(2,715 Views)

The front panel was unresponse before I click it.  It won't even response to my first click.  Timeout case for the event structure can't lock the FP, right?  Sorry, I can't post the code on this one.  

------------------------------------------------------------------

Kudos and Accepted as Solution are welcome!
0 Kudos
Message 3 of 5
(2,706 Views)

Hello,

 

There are a couple of pieces of information which would be useful in determining why your VI is freezing. Do you see your processor usage spike when running the EXE? Any increase in CPU usage/memory? I assume the VI was running fine in LabVIEW 8.5? You might try recompiling with debugging enabled. Does the VI run correctly in LabVIEW before it is compiled?

 

You might also try reading through this document on how Event Structures can cause VIs to lock up:

 

http://digital.ni.com/public.nsf/allkb/D979D150E9FC253C86256BC7006F3E22?OpenDocument

 

I hope this info helps! Let us know what you find out.

 

Andy C.

Applications Engineering

National Instruments 

 

 

Message 4 of 5
(2,674 Views)

It turned out that the program went into an infinite loop due to an invalid path.   Thanks!

------------------------------------------------------------------

Kudos and Accepted as Solution are welcome!
0 Kudos
Message 5 of 5
(2,664 Views)