LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Data Dropout Cured by LabView Restart

Our Test Lab has a SCXI-1000 with 3 SCXI-1303 cards reading pressure and temperature sensors.  Recently, we have seen an issue where all the temperatures and pressures are shifted to incorrect values during the same second.  Many of the NTC temperature sensors increased 40-60°F.  Many sensors that were not being used and were reading 0, started reading values.  Some other sensors that were reading values started reading 0.

 

We were able to correct the problem by simply closing LabView and opening it again.  Has anyone seen this issue before and determined a cause?

0 Kudos
Message 1 of 5
(460 Views)

Likely some cabling was disturbed when someone walked by.

-Santhosh
Semiconductor Validation & Production Test
Soliton Technologies
NI CLD, CTD
LabVIEW + TestStand + TestStand Semiconductor Module (2013 - 2020)
NI STS for Mixed signal and RF
Message 2 of 5
(436 Views)

Can you post any of the actual code that does the data gathering?

 

How long does it take for this to happen (minutes, hours, days)?  Is it consistent or does it happen after a random amount of time each time?

 

If it's not a physical problem (i.e. cable bumped or whatever) then it could be some sort of internal buffer/counter/register that fills up over time.  

 

Did it just happen the one time or is it a repeatable problem?

Message 3 of 5
(433 Views)

It has happened twice in the past few weeks, both times when recording data.  Previously, it was running for around 7 years without seeing this issue.  When we see the issue we were able to correct the issue by restarting the LabView program.  

 

There is quite a bit of code involved in the logging, but it looks like it is all put into a Build Array and sent to a Array To Spreadsheet String.  The error is occurring before the file is written.

 

Thanks for the clue on the buffer/counter/register!  We did get a new technician and I wonder if he is logging for a longer duration than the previous one.

0 Kudos
Message 4 of 5
(419 Views)

@Matt_TestLab wrote:

There is quite a bit of code involved in the logging, but it looks like it is all put into a Build Array and sent to a Array To Spreadsheet String.  The error is occurring before the file is written.


This sounds like you should be using a Producer/Consumer setup so that you can log the data as it comes in.  Otherwise, you might be running into a memory issue.

 

But your initial statement makes me think you do have an indexing issue.  We would need to see code to diagnose that any further.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 5 of 5
(171 Views)