LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQmx Requirements

Solved!
Go to solution

 

   I am being handed some code from a member of my company, when I try and load the code into my LabVIEW system I see:

"File 'convert 1DWfm to DDT.vi' not found". There are also a host of other DAQ objects it can not find

 

This would lead me to beleive that DAQmx is not insalled, however, If I look in a list of all objects I can use the following objects ARE available:

Traditional DAQ Channel

DAQmx Switch

DAQmx Terminal

DAQmx Task Name

DAQmx Scale Name

DAQmx Device Name

DAQmx Global Channel

DAQmx Physical Channel

 

 

When I insert the "Device Drivers" disk and attempt to install the device drivers I ammet with the following error "Error 1921. Service 'National Instruments LXI Discovery Servic' (niLXIDiscovery) could not be stopped." - Even though I have administrator privilages on this PC.

 

Please can someone help me! I am using LabVIEW 2009 (Note: the code I am upgrading is LabVIEW 7.1 Code)

0 Kudos
Message 1 of 5
(3,128 Views)

Whoa! 7.1 to 2009 is a bit of a jump!

 

Alright- you may be a bit late to move but you are moving HOWEVER, It is important to bare in mind that not all versions of DAQmx have support for all Versions of LabVIEW

 

Here

is a great link for information about the do's and gottcha's of moving to DAQmx from traditional DAQ

 

The Read-me

file for the latest DAQmx (9.0.2)  release shows support for LabVIEW versions 8.20x (why did they drop the 0 from .20 it was a signifgant marketing event at 20 years) and later ONLY.

 

You can have only 1 version of DAQmx installed at a time but many versions of LabVIEW. 

 

Your best bet would be to find a DAQmx version that supports LV7.1 and 8.20 and rev your code to LabVIEW 8.20 as an intermediate step.  Then update to DAQmx 9.0.2 and rev the vi's up to 2009f3


"Should be" isn't "Is" -Jay
Message 2 of 5
(3,098 Views)
Solution
Accepted by alecjcook

In the end, I opened the task manager and ended the process "niLXIDiscovery". Don't know why I didn't think of that at first.

Thanks for your help!

0 Kudos
Message 3 of 5
(3,070 Views)

I am interested in the oposite.  I have both LV2009 and LV7.1.  I need to write code in LV7.1 and for some reason the DAQmx VI's are gone???

 

 

0 Kudos
Message 4 of 5
(2,741 Views)

First off, it's a bad idea to add to a solved thread, most people don't bother reading them anymore.

 

To answer your question though, it's because your DAQmx version doesn't support both LV7 and 2009.  Look in the chart linked above to find out if there's a version that supports both AND all the hardware you will use.  If not you are stuck with re-installing DAQmx every time you want to use a different LV version.  This is one of the biggest pains with LabVIEW but you just have to deal with it or byte the bullet and upgrade all your code to the latest versions.

LabVIEW Pro Dev & Measurement Studio Pro (VS Pro) 2019 - Unfortunately now moving back to C#, .NET, Python due to forced change to subscription model by NI. 8^{
0 Kudos
Message 5 of 5
(2,720 Views)