From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't uninstall LabVIEW Run-time Engine 2013

Solved!
Go to solution

I have a PC which had both the LabVIEW Run-Time Engine 2013 installed and the LabVIEW 2013 development environment.  I uninstalled the LabVIEW 2013 development environment, and now executables will not run.  They say that the 2013 Run-Time is not installed.  However, the 2013 Run-Time is listed in MAX.  It does not show up in the list of software available to uninstall, so I can't seem to uninstall and reinstall it either.  When I try to run the 2013 Run-Time installer, it says that the Run-Time is already installed.  It appears I'm stuck with a corrupted Run-Time installation?  Is there anyway to completely remove the Run-Time so I can reinstall it properly?

 

Thanks

0 Kudos
Message 1 of 8
(6,231 Views)

Hmm, that's really odd.  I must admit, I just went looking and could not (reliably) find where the LabVIEW Run Time Engine "lives".  You are certainly right that MAX has a pretty complete list (on my machine, it shows RTEs from 2009, then 2011 through 2016, though I'm pretty sure I've uninstalled 2009, 2010, and 2011 from Control Panel).  I thought, "Well, if MAX sees them, then let's get MAX to uninstall them", but choosing Add/Remove Software just takes you back to Control Panel Programs and Features.

 

I hope someone from NI is seeing this (or one of our more experienced colleagues) ...

 

Bob Schor

0 Kudos
Message 2 of 8
(6,176 Views)

Hello,

 

can you install for example Run-time Engine 2014? or any other version? It may be temporary workaround...

 

Marcin

              

Think Dataflow - blog.mtapp.tech
0 Kudos
Message 3 of 8
(6,168 Views)

I could try for debugging purposes, but the executable I need to run needs the 2013 Run-Time.

0 Kudos
Message 4 of 8
(6,085 Views)

@robert.smith wrote:

I have a PC which had both the LabVIEW Run-Time Engine 2013 installed and the LabVIEW 2013 development environment.  I uninstalled the LabVIEW 2013 development environment, and now executables will not run.  They say that the 2013 Run-Time is not installed.  However, the 2013 Run-Time is listed in MAX.  It does not show up in the list of software available to uninstall, so I can't seem to uninstall and reinstall it either.  When I try to run the 2013 Run-Time installer, it says that the Run-Time is already installed.  It appears I'm stuck with a corrupted Run-Time installation?  Is there anyway to completely remove the Run-Time so I can reinstall it properly?

 


What else do you have still installed? (i.e. what else shows up in the "National Instruments Software" tool)

0 Kudos
Message 5 of 8
(6,016 Views)

Here's screenshots of the NI software available for uninstallation, and the software listed in MAX.  As you can see, the LabVIEW 2013 Run-Time is not in the uninstall list, but it is in MAX.

Download All
0 Kudos
Message 6 of 8
(5,945 Views)

It doesn't seem to show run-time engines for LV 2010 or 2011 either even though they show up in MAX.

 

But your add/remove programs still shows LabVIEW 2013 32-bit installed.

0 Kudos
Message 7 of 8
(5,929 Views)
Solution
Accepted by topic author robert.smith

I figured it out.  I was able to uninstall the run-time engine by following the instructions here: http://digital.ni.com/public.nsf/allkb/F4B8D92A304E4A7B862577460072002F

Message 8 of 8
(5,864 Views)