Showing results for 
Search instead for 
Did you mean: 

Application builder fails. Error Code -12, 32



I'm trying to build an EXE from a simple application, and I cannot get the builder to succeed. Here is the error that was generated: >> >> >> >> >>

Loading product deployment information
Adding files to installer
*** Error: Windows SDK function returned an error. (Error code -12)
The process cannot access the file because it is being used by another process.

*** Error Details:
Error in MDF API function: _MDFBuildDevPart_SetUpgradeInfo
     Could not rename msi (source = C:\LV_Projects\builds\GC_Installer\GC_Installer_v1.2\temp\dp\devpart.msi; destination = C:\LV_Projects\builds\GC_Installer\GC_Installer_v1.2\temp\dp\install.msi)
Windows function MoveFileEx returned an error. Error code: 32
*** End Error Report
*** Error: Windows SDK function returned an error. (Error code -12)
*** Error Details:
Error in MDF API function: _MDFBuildDevPart_Close
Error in MDF::BuildDeveloperPart::Close.
ERROR: Caught MSI Exception:
<Unable to format error record.>
MSI error code: 6
*** End Error Report

Visit the Request Support page at to learn more about resolving this problem. Use the following information as a reference:



Any suggestions, or is there any further information I can provide? I am using Labview 2010.



0 Kudos
Message 1 of 6



Please follow this article that explains the misbehavior you are experiencing with possible solutions.



M. Whitaker
0 Kudos
Message 2 of 6

Thanks for the response. However, I looked through the article, and it does not seem to be applicable to this case because I am not attempting to include any of the listed drivers. For my program, I am only referencing standard Labview VIs and one DLL driver for the instrument I am working with. 


I actually tried simplifying the problem by creating an exe build of a while loop with a button. When I tried to create an installer for this program, I got a very similar error.


Ultimately, I found that I was able to build an installer if I performed some combination of building an exe of my program, running the exe, stopping it, keeping the program in memory, etc. I am not entirely sure what is happening, and it is very convoluted. It is not a reliable way for me to get an installer to build for my program.



0 Kudos
Message 3 of 6

I haven't run into an error like that, but whenever I see an "access denied because someone is already using the file" I always suspect another player. The most common sources are the anti-virus program and the Windows file indexing service. I would start by disabling the anti-virus and seeing if that helps.

Try to take over the world!
0 Kudos
Message 4 of 6

Thanks, that's a good point. Next time I attempt to compile I'll try to identify if any other program is interfering.

0 Kudos
Message 5 of 6

I had this error 32 problem as well and found this thread.


I had downloaded the DAQmx v 9.7.5 from the web site, unpacked it to the default temporary directory and installed it. I did not delete the temporary directory.


I tried to include it as an Additional Installer in the Application Installer build for my project with the option "To minimize media prompts while building your installers, copy the selected installers and all future installers to this computer" checked.


This gave me the error 32.


If I unchecked the option (ie not copy the installers) it built ok.


When I looked at thetemporary folder with the unpacked downloaded installers for DAQmx 9.7.5 in I found that some of the files were read-only.


I made the foder and all sub folders and files read-write and then I could enable the "copy the installers" option, and my installer built with no errors.


I hope this might help be the solution to someone elses error 32 problem.




Message 6 of 6