LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

An error occurred while running LVCompare.

I likely has something to do with environment variables. The same error occurs when running the following explicitly from the MSYS2 terminal when LabVIEW is already running:

 

'C:\Program Files (x86)\National Instruments\Shared\LabVIEW Compare\LVCompare.exe' a.vi.vi a.vi

 

But it works when running from Microsoft Windows [Version 10.0.19045.3803] terminal when LabVIEW is already running:

 

"C:\Program Files (x86)\National Instruments\Shared\LabVIEW Compare\LVCompare.exe" RawSocketTestClient.vi.vi RawSocketTestClient.vi

 

I also found C:\msys64\tmp\LVCompare.ini (... cut):


[LVCompare]
vi1 = "C:\\...\\a.vi.vi"
vi2 = "C:\\...\\a.vi"
attr = TRUE
fp = TRUE
fppos = TRUE
bd = TRUE
bdcosm = TRUE
bdpos = TRUE

0 Kudos
Message 11 of 13
(303 Views)

That's not the default temp folder for a LabVIEW installation.....

I revert to my original question.. is the Temp folder in your LV settings the default or not?

What happens for me is that LVCompare creates the ini in the place where I have set as a temp folder, but LVCompare, when running, looks for it in the default folder.

Maybe there's an interaction between the LV IDE and LVCompare when the IDE is running, no idea, but this looks strangely like something I've observed before.

0 Kudos
Message 12 of 13
(285 Views)

The error occurs when LabVIEW and LVCompare are started from difference environments. LV Options, Path... setting reflects the environment's TMP folder variable which LVC apparently uses also so TMP must be set the same in each environment for them to work together.

 

LV & LVC started from Windows terminal:

okay

 

LV & LVC started from MSYS2 terminal:

okay

 

LV started from Windows Explorer/Terminal; LVC from MSYS2 terminal:

An error occurred while running LVCompare.

NI_LVConfig.lvlib:Load.vi<ERR>
C:\Users\<user.name>\AppData\Local\Temp\LVCompare.ini does not exist

 

LV started from from MSYS2 terminal; LVC from Windows Terminal:

An error occurred while running LVCompare.

NI_LVConfig.lvlib:Load.vi<ERR>
C:\msys64\tmp\LVCompare.ini

0 Kudos
Message 13 of 13
(271 Views)