Showing results for 
Search instead for 
Did you mean: 

Actor Create Executable Anomally



I have a horrible feeling I'm going to look really stupid after posting this, but if I'm doing something really obvious and wrong then I'll take that over the struggle I'm currently having getting an Actor Framework to run as an executable!


I have built an Actor Framework application that relative to some of the ones I've done before is incredibly simple, and in fact I've stripped everything back to having a VI that launches an actor with the front panel shown an overridden core that displays a boolean button connected to an LED on the front panel - simples, but it doesn't work (see picture).


Actor Launcher


It's fine in development mode, but built into an executable the launcher VI runs, but fails to launch the Actor.


Here's what I've tried so far :-


  • Tried LabVIEW 2012 instead of 2013 - doesn't work.
  • Created a framework from the Alpha and Beta built in template - this builds and works without a hitch.
  • Tried calling launcher vi by reference - doesn't work.

Does anyone have any ideas why this isn't working, or anything massive that I've totally missed - as said I've done 2 or 3 projects now with Actor with no issues, so I really cannot understand why I should have a problem with this.


Appreciate any ideas for why this isn't working,



David Clark
IDEX Biometrics UK Ltd
Hampshire, England
0 Kudos
Message 1 of 5

My first guess since it works in development but not in exec is that something isn't being loaded into memory.  I'm not sure what it would be since you have the class constant on the block diagram.  Have you tried adding the class to your build source to be "always included"?  Not sure if this is necessary but just a thought.  

Message 2 of 5

Two suggestions:

  1. Look at the error output of the launch VI.
  2. My guess is that this doesn't work because the FP of the core VI is stripped. I can't check, but I'm assuming that by default there's nothing which causes it to be kept when building. This is easy enough to check by creating a property node for one of the controls on the FP of the core VI.

Try to take over the world!
Message 3 of 5

Thankyou both for your suggestions, luckily in the meantime I have sorted out the problem by going back to the Actor template and then changing values until I killed it.


The solution is as follows :-


  • When you call 'Launch' do not set 'Open Actor Core Front Panel? (F)' to true.
  • In your overriden Actor, go into properties and in Window Appearance customize by setting 'Show front panel when called' and 'Close afterwards if originally closed'.


Thanks again,





David Clark
IDEX Biometrics UK Ltd
Hampshire, England
0 Kudos
Message 4 of 5

Yes - have already tried that - should've listed it.


Thanks for the reply.

David Clark
IDEX Biometrics UK Ltd
Hampshire, England
0 Kudos
Message 5 of 5