Showing results for 
Search instead for 
Did you mean: 

-1073807339 temperature controller

Good day,


I got error code -1073807339. The labview programs seems to be able to send data inside the whileloop, but an error occurs while writing the data. Furthermore when I restart the VI sometimes the data wont make it inside the whileloop. See second picture.


I use an omron E5DC temperature controller. I simply want to regulate the temperature via the computer.

NI Visa interactive controls says: 

Error opening resource:

VISA: (Hex 0xBFFF0072) The resource is valid, but VISA cannot currently access it.

By the way, selecting COM 5 as source gives the same result.


Help is very welcome, 

greetings Jonas



but sometimes:





0 Kudos
Message 1 of 11
Hi Jonas, have you tried any other ways of communicating with this device? (Terminal program, vendor software, etc.?)
Do you have any connections open to the device? You should close those first. Also, make sure you don't have it selected in NI MAX, this can sometimes reserve a resource. Are you closing the connection at the end of your VI?
Finally, you should use "shift terminals" on references that enter a while loop. (This is more of a good practice, won't necessarily address your problem).
0 Kudos
Message 2 of 11

Hey Gregory, thanks for the fast reaction:). LabView is the only program using the usb device, I am closing the while loop and I only saw in the device manager that the 'usb device is working correctly', but that doesnt say much. Other programs seemed at least as advanced as LabView to test the set up?

I updated the modbus package and the error changed to a less vague one but Im still not sure what's wrong. 


Error 56 occurred at RTU Data Unit.lvclass:Read ADU

Possible reason(s):

LabVIEW: (Hex 0x38) The network operation exceeded the user-specified or system time limit.





0 Kudos
Message 3 of 11

It looks like you aren't talking to the device yet. What are you using for the VISA Resource and Unit ID?

0 Kudos
Message 4 of 11

Thanks for replying again. The ID of the omron temperature controller U-No is also set to 1. 

If I disconnect the usb port, ''com4'' disappears correctly as well. Is there something else I can check?



0 Kudos
Message 5 of 11

Hmm Now I see that the 'adress' and the 'register to write' in the Write subVI are set to 0 (see picture). Maybe these should be filled in with something else, but I didnt figure out yet with what since the documentation . Doesnt mention it clearly. Not sure if this causes the error.



0 Kudos
Message 6 of 11
Hi Jonas, please upload your code here.
It seems like the connection info gets lost at some point. It could be that this happens after the error, and not necessarily the cause of the error.
I would try running the program without a while loop as well, to make sure you're seeing the source of the error.
0 Kudos
Message 7 of 11

I will try it thanks. This is the code which is still containing the whileloop. I did not delete it yet since I can't use the omron device until tomorrow anyway. 

0 Kudos
Message 8 of 11
Hi Jonas, I realized in your screenshot above you are looking at functions from "Modbus API.lvclass" and "Modbus Slave.lvclass", but the actual function that gets called should be from "Modbus Master.lvclass".
0 Kudos
Message 9 of 11

Yes I have used the 'modbus library' package. The modbus master class seems to give the same errors.

0 Kudos
Message 10 of 11