Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

keithley 2440 source meter, 4 wire measurement

Solved!
Go to solution

Dear all,

I'm using keithley 2440 sourcemeter to measure the resistance value with 4 wire. I downloaded LabView driver, tested an example program , and

it works fine.

I tried to measure the resistance with 4 wire, so I put the "Enable Remote Sensing.vi" before the "Read Single.vi" , but it generated the error "#803"

which is "Not permitted with OUTPUT off". If I disabled the Remote Sensing, then it works with 2 wire mode.  I'm using LV8.2 and I've attached the program.

 

Could you help me with figuring out this problem?

 

Thank you very much.

 

Yoon

0 Kudos
Message 1 of 6
(6,993 Views)

Yes I can help.

 

The "instrument" you are using is (accordring to it's manual) IEEE-488.1 compliant.

 

 So we merely need to learn what the IEEE-488.1 spec requires (RIGHT?)

 

OOPS-------

Keithley made up its own 'pseudo-specification' "488.1" so, NO (exactly zero) defined required responses exist to any GBIP queries.

 

 

You have to read the manual and the user's guide for the 2440 and forget about IEEE 488 or IEEE 488.2 referances.  Keithley ignores these standards as well!   (and tries to pass off non-exestant ""standards"" like IEEE 488.1 as well) 

 


"Should be" isn't "Is" -Jay
0 Kudos
Message 2 of 6
(6,985 Views)

Thank you for your reply, Jeff.

However, I rarely understand what you are talking about. :mansad:

 

So,you mean that I should get rid of the attached vi ? What vi should I modify ?

 

Thanks.

 

WYoon

0 Kudos
Message 3 of 6
(6,971 Views)

Well, I also fail to see the relevancy about Jeff's comments about 488.1/488.2 as well. The communication to the instrument is obviously fine. You have no problems with the low level protocol and the functions in the driver aren't using them anyway.

 

It would seem that there is a configuration step that needs to be run first or one of the configuration steps that you did perform is conflicting with the 4 wire option. You are sending the Enable Output but the error message indicates that the outputs are not enabled. What I do when first trying a new instrument, is first configure it manually. I then determine what commands need to be sent in order to reproduce the manual operation. If I would have an error like you are seeing, I would try to program the instrument in MAX with the interactive control. I would just use the commands from the manual that I thought were necessary. If the interactive control works, you could try to find what the differences are between the LabVIEW code and what you sent in MAX. Using NI-Spy is invaluable in capturing all of the commands. If you are unable to setup the instrument in MAX, then it's probably time to contact Keithley. Make a list of all of the commands you send and ask Keithley what might be missing or incorrect. Trying to describe a LabVIEW program to them is probably a waste of time but a list of commands from their manual is something they should understand.

Message 4 of 6
(6,964 Views)


swsyoon wrote:

Dear all,

I'm using keithley 2440 sourcemeter to measure the resistance value with 4 wire. I downloaded LabView driver, tested an example program , and

it works fine.

I tried to measure the resistance with 4 wire, so I put the "Enable Remote Sensing.vi" before the "Read Single.vi" , but it generated the error "#803"

which is "Not permitted with OUTPUT off". If I disabled the Remote Sensing, then it works with 2 wire mode.  I'm using LV8.2 and I've attached the program.

 

Could you help me with figuring out this problem?

 

Thank you very much.

 

Yoon


In your first sentence you said you could measure 4 wire.

 

I would try two things.

 

1. Get rid of the Enable Remote Sensing.vi  - to me that sound like it is used for setting the output voltage not for 4 wire.


2. Make sure you are giving your instrument the commands in the correct sequence.  

Brian
0 Kudos
Message 5 of 6
(6,963 Views)
Solution
Accepted by topic author swsyoon

Thank you very much for your reply.

I read the manual and I found that the sequence of the two subVI was wrong. The sequence of the "Enable output.vi" and "Remote sensing.vi" have to

swith each other. I attached the block diagram.

 

I appreciate all.

 

W.Yoon

 

0 Kudos
Message 6 of 6
(6,930 Views)