Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW 2020 Professional Required Software for Raspberry Pi Project

I am using LabVIEW 2020 Professional with NI LabVIEW LINX Toolkit instead of the LabVIEW 2020 Community Edition and found some software requirements I did not expect.  As can be seeing in the image below if I only install LabVIEW 2020 Processional and try to open a project that included targeting a Raspberry Pi I get an Unsupported Item error.

 

Raspberry Pi Project with LabVIEW 2020 ProfessionalRaspberry Pi Project with LabVIEW 2020 Professional

 

For this example I used the Simple-Pi-WebVI-WebSockets project by MediaMongrels.  Note: This project also requires the WebSockets package available in VIPM.

 

VIPM Raspberry Pi ProjectVIPM Raspberry Pi Project

 

What I found is that LabVIEW RT 2020 also needed to be installed for the project to successfully open.

 

LabVIEW 2020 Professional with LabVIEW RT 2020 and Raspberry Pi ProjectLabVIEW 2020 Professional with LabVIEW RT 2020 and Raspberry Pi Project

 

This makes sense to be because from what I have read the LINX Toolkit targets the Raspberry Pi like a RT device but I have not found any information on what the minimum software requirements are for a Raspberry Pi project with LINX.  I am one who only like to install the minimum software required to make sure I understand why everything is needed so I am wondering if anyone has some additional information on this subject.  Maybe all of RT does not need to be installed but just some driver?  I assume all of LabVIEW RT is not included with the LabVIEW Community Edition so there is probably some subset of LabVIEW RT that is required.

 

At the very least maybe this post will help someone else who is starting a Raspberry Pi project with LabVIEW Professional.

David Wilt
The New Standard LLC
0 Kudos
Message 1 of 5
(3,230 Views)

Hey,

    I am facing issues in connecting my raspberry pi 3  with LabVIEW 2020 SP1, fulfilled all requirements, by following this tutorials https://www.instructables.com/Getting-Started-With-the-Raspberry-Pi-2-LabVIEW/   

downloaded 

linix by digilent/ labview makerhub suppoerted for labview 2020.

rpi is in working condition.

ssh is enabled

 

 

but when i tried to connect via 

LINX Target Configuration 

 

it shows me error

 

device interrogation failed: unable to connect to target

 

 

 

0 Kudos
Message 2 of 5
(2,605 Views)

faizan123,

 

If you following the instructions that the link you provided then you probably messed something up as those instruction are for LabVIEW 2014 when LINX was not officially part of LabVIEW.

 

If you are using LabVIEW 2020 SP1 Professional edition then you will need to install LabVIEW 2020 RT and the LINX toolkit from VIPM as I have stated here.  I have included images of the correct software version so you can verify you have everything correct.  If you installed an older version of LINX it will not work.  You will need to uninstall what you added and install the correct version from VIPM.

 

Confirm that you have installed the correct software and if you still get an error please provide images so we can exactly see what you are referring to.

David Wilt
The New Standard LLC
0 Kudos
Message 3 of 5
(2,592 Views)

Were you able to connect to Raspberry pi? What procedure did you use? I am wondering if I follow the video from 2016, install raspbian 2016 and use linx 2020 version target connection, will it work with 2020 sp1 Labview professional version + the RT packages you mentioned?

 

 

0 Kudos
Message 4 of 5
(2,221 Views)

I had no problems connecting to the Raspberry Pi with LINX with the software I listed here.

David Wilt
The New Standard LLC
0 Kudos
Message 5 of 5
(2,206 Views)