Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

LINX Raspberry PI 4 Target - Initial Setup Issues

Solved!
Go to solution

Hi all, 

 

My objective is to use LabVIEW 2021, the LINX toolkit, and a Raspberry Pi 4 Model B to communicate to device over UART connections. 

 

I have installed the LINX toolkit and have been able to connect to the Raspberry Pi 4. I can create, deploy, and execute LabVIEW VIs on the target. 

 

Problem that I have is that I cannot make the demo code work properly. I have not been able to control the LED from the demo VI. In the screen shot below, the error message makes reference to a raspberry pi 2 model B. It seems to me that I have the wrong target configured in the project. 

 

Lonald_1-1651761688046.png

 

Currently I am getting the following options when I attempt to add a target.

Lonald_2-1651762505293.png

 

My questions:

Does the toolkit support a raspberry pi 4? (based on other posts I have read, it seems the answer is yes)

How do I properly configure a raspberry pi 4 model b to be a target in my project?

Will I be able to use the UART Channels on the raspberry pi 4?

(Hate asking this one) Am I better off using Python to perform this task?  

 

Thank you. 

 

 

 

 

 

 

0 Kudos
Message 1 of 3
(328 Views)
Solution
Accepted by topic author Lonald

I can confirm that the Raspberry Pi 2 B is the correct device to use.  LINX was never updated to display later versions of the Raspberry Pi but this is not an issue.

 

I have not ran the Blink example myself as I had no need so I cannot confirm what setup is correct but looking at other posts you can see that this example works:

My only thought tis that DO Channel 6 does not work for this purpose for some reason.  I know that some IO are taken over by LINX and this may be one of them.  Did you try pin 7, which is DO Channel 4 I believe?  Do any of the DO Channels work without an error?

David Wilt
The New Standard LLC
0 Kudos
Message 2 of 3
(270 Views)

David, 

 

Thank you for your response. I tested all output channels and found that many channels report the following error message: The specified Digital Output channel (x) is not available on the Raspberry Pi 2 Model B.:

 

I initially tested channels 7, 6, and 24  and based on the error messages, I assumed there was a hardware / driver compatibility issue. (Note: channel 7 did not error but appeared to not function. I was connected to pin 26 (GPIO7))

 

Now I understand that "DO Channel" refers to the header pin number (not the pin label). I was assuming that channel 21 was "GPIO21" which resides on pin 40. 

 

To be clear: when I set channel 40 high, header pin 40 goes high. 

 

This is my first attempt to use the Raspberry Pi to control digital signals. Thank you for helping me through this issue. 

 

-Lonnie

 

 

0 Kudos
Message 3 of 3
(259 Views)