Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

Error 5004 when trying to use the Read VI for ultrasonic distance sensor on Raspberry Pi

I am trying to use LINX (on LabView 2014 32 bit version) to read distance from HC-SR04 ultrasonic sensor that is on a Raspberry Pi 3B. I am able to connect to the RPi and run the Blink example.
I have followed this video: https://www.youtube.com/watch?v=qlbw9MDr6OM&list=PLuzyRQYQpuVgdtuz64nKeUy6V5ygw4Wuk&index=4&ab_chann...

and ended up with the following VI and error.



I should mention I followed the advice in the video and changed the Read.VI by adding an Active High control to the Stimulus Pulse (tried with and without this modification).
Also, I am able to read distance from the sensor on the RPi with a Python script, so that works.

I've tried using LabView Community edition 2020 but I couldn't even connect to the RPi.

0 Kudos
Message 1 of 2

Did you get this figure out? I'm running into the same problem.

0 Kudos
Message 2 of 2